Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi all,
any help/advice greatly received.

My car keeps going into "Limited Performance". No engine management light just the words and the picture of the car with a spanner sticking out of the roof in the info display. No fault codes.

I had thought EGR but I've just done two half hour drives at 70 in fourth gear to clean out the egr, looked into the egr and it is good. This is really bugging me. without any EML or codes I haven't got a scooby as to what is wrong.

Does anybody have any ideas?
 

·
Super Moderator
Joined
·
3,071 Posts
Hello Condyboy,what sort of code reader are you using ?
What year is the 9-3 ? . Without codes we could be guessing as to the problem,
have you had the EGR off or just looked with it fitted .
You could check intercooler pipes for splits or signs of oil mist around them
depending on what year it is could be DPF is clogged ( if one fitted depending on year of car )
but at the mo it's guess work .
quick look back on your old posts found out it's a 2007 and I see you have had a few issues with that car .
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Hi sorry,
Yes it is a 2007. Has had a replacement engine after my old one blew it's head after a clutch was fitted! replacement engine was 350 nicker from a scrap yard. I have fitted a new turbo, timing kit and fully serviced the car. There are no codes to be read (i'm using a generic code reader called 'OBD Can elite') not getting any fault codes. EML light is not coming on. Just the warning on the info display saying 'Limited performance'. This car is lovely to drive when it's working, but it is being a real PITA. I have had the EGR off and cleaned it, I have tried the 'Italian tune' to clear the DPF and nothing seems to work! I am at the end of my tether with this SCAAB. might just peel it off and throw away! sick of spending good money after bad on it! Any pointers happily received.
 

·
Registered
Joined
·
1,169 Posts
If you are getting a limited performance message and limp mode then there will be code.
Cheap option is Opcom which has a good chance of finding the problem or a Tech2 to be sure.
 
1 - 4 of 4 Posts
Top