Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4,215 Posts
Discussion Starter · #1 ·
Got my aero back from the gearbox re-build
now the cruise control works ???...It has not worked since AR re-buit the gearbox 100,000 mies ago..

not complaining but ?????
Also the speedo is reading fast ...?
 

·
Registered
Joined
·
8,216 Posts
Mine hasn't worked either since Abbott had the gearbox out. Subsequent rebuilds didn't fix it either. They didn't do anything at the clutch pedal? I'm assuming (never looked) that mine is something to do with the pedal switch or wiring.

Can't explain the speedo, though. It's driven from the secondary side of the final drive so should be the same regardless of the gearbox or final drive ratio.
 

·
Registered
Joined
·
3,892 Posts
Obviously AR didn't reconnect something up properly in each case....
Mind you my dealer had to readjust the gear linkage thingy (very technical
) after AR had done the LSD on my Aero, as the gearchange was decididly notchy afterwards.

As for the speedo, are there different ratio speedo drive cogs for different models, and the've put in a new one of the wrong type....otherwise can't think of anything else it could be....
 

·
Registered
Joined
·
16,524 Posts
As for the cruise control, make sure that the brake and clutch pedal switches are in contact with the pedal when you are not touching the pedal. They are self adjusting in one direction only, so if the pedal is a bit lower than it was before the gearbox change, the switch will think you are braking or operating the clutch and turn the cruise off. Switch just pulls out on a ratchet I think.

Can't think of anything else it could be. But I thought that if the car thought the brake was being used it cut the boost. May be that's only on the brake light switch (are there two brake switches?) ot Trionic 5 is different.
 

·
Registered
Joined
·
14,305 Posts
I don't see anything directly related to the gearbox that should affect cruise, assuming your speedo is still working
It's not even as though there's a mechanical clutch link of any sort that could be moved

Having said that, mine's been in and out many times at Wix
, but never had a problem with cruise.
 

·
Registered
Joined
·
8,216 Posts
Originally posted by aeropilot:
[qb]Mind you my dealer had to readjust the gear linkage thingy (very technical    :rolleyes:    ) after AR had done the LSD on my Aero, as the gearchange was decididly notchy afterwards.[/qb][/b]
Forgot about that - I had to adjust mine too. Could hardly select 5th gear at all after they'd been at it. Took it back but they'd just closed so put up with it and did the job myself when I got home. Not a big job but really annoyed me after the very substantial amount of money I'd just paid them.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top