Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 6 of 6 Posts

·
Registered
Joined
·
776 Posts
Discussion Starter · #1 ·
Hi all/

Long time, no speak.

Car running great until today. I Have tried to start car 3 - 4 time during day, and each time have had real trouble turning the key ( steering not locked on or anything) !

Anyway, same problem tonight, and when finally turned key round, the little oil can lit up, as it always does, (it always goes out after a while of course, cant remember if after engine starts or not, but it stays on) But problem is that when the display diagnostic has done it stuff,as well as little oil can staying lit,i the "check engine" logo starts to flash, goes out, comes on, starts to flash etc...
(car not with me tonight, but it flashes quite a few times). Can anyone give me or my local mechanic a head start please as to what it may be ?? ( depending on number flashings) ??

Could the ignition barrel problem be linked, seems too much of a coincidence..

Oh yes, MOST IMPORTANT, car engine turns over, but will not fire up at all ....So not just annoying lights flashing, its BROKEN DOWN.....

Cheers, Andy
 

·
Registered
Joined
·
776 Posts
Discussion Starter · #2 ·
Ok then, I have looked in archives, understand and printed out all the flashing code details for reference....
But, still think it more than coincidence because I have had so much trouble with ignition lock barrel today, and it has immediately rolled into this other problem, with check engine lights, and car wont start at all..

Cheers, Andy
 

·
Registered
Joined
·
776 Posts
Discussion Starter · #4 ·
I popped car into mechanic without warning this morning, he had limited time to look at it.

As stated, It seems to have immobilised itself, and after checking some electrics, it appears no power is getting to the fuel pump.

I never use the alarm "zapper" I just lock and unlock car (naughty I know). He suggested getting zapper, which might re-mobilise system by very fact of zapping it.

However zapper DIDNT work ( I mean zapper didnt unlock car or stop alarm screaming),although I know zapper is in good order. Car was having none of it, and stays immobilised.

He will look again tomorrow, take off ignition cowling, and try to check ignition-to-alarm feeds.

Anything else he could look for, he an excellent mechanic, but this is an awkward one...

Thanks in advance,

Andy

p.s. In case anyone doesnt know, car is a 9000 CSE 2.3T, FPT,199, L Plate, Trionic(Abottised). I gather alarm is non standard one (Cat 1 he says, whatever that means) He says dismantling that properly is a last resort...

Cheers
 

·
Registered
Joined
·
103 Posts
I'd guess that you have 2 separate faults.
If you can count the number of flashes of the 'check engine light' then it will give you something to go on. The ignition lock may cause non-start but only if the power to ECU or fuelling etc is missing.
Anyone out there got any other ideas?
wayne
 

·
Registered
Joined
·
776 Posts
Discussion Starter · #6 ·
Thankyou Wayne/.

The number of flashes seem to indicated the Llamba sensor, but that wouldn't stop car firing or anything would it??

More likely ignition lock unit problem, as:

A/. I had, as mentioned, a big problem fiddling with to actualy turn the key immediately before problem.(one followed the other)
B/. Car wont fire up at all.
C/. No power getting to fuel pump.
D/. Remote control Zapper is not broken, but it fails to make anthing move or bleep (apart from red light flashing on zapper itself)

?????

Cheers, Andy.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top