Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 11 of 11 Posts

·
Registered
Joined
·
4,215 Posts
Discussion Starter · #1 ·
This has happened to me three times now ..twice on the way home tonight
The problem sarts with a hesitation as the aero comes on boost except it does not come on boost the tcs (groan ) light comes on and it goes into limp home mode
however a quick ignition off and on and it resets itself
the wierd thing being that the petrol tank is now showing empty with the light on (it was a 1/4 full ) and the computor is showing 20 miles to empty
over the next minute it recovers back to what it was before and the car is flying now...

anyone seen anything like this before ?
I will be taking it in to get the tech 2 for the fault codes
any ideas ?
 

·
Registered
Joined
·
14,305 Posts
Originally posted by ylee coyote:
[qb]I will be taking it in to get the tech 2  for the fault codes
any ideas ? [/qb][/b]
And I bet the damn thing won't pull anything useful


Just a distant thought tho... maybe there's a fuel leak or summit under pressure... as the comp calculates DTE based on the avergae of your last 10 minutes of driving. Maybe it's getting it's knickers in a twist about that.

Failing that, I'd put it down to the curse of ETS.

Sorry that's not a huge help
 

·
Registered
Joined
·
8,948 Posts
the wierd thing being that the petrol tank is now showing empty with the light on (it was a 1/4 full ) and the computor is showing 20 miles to empty  [/b]
I would have thought that this would only be when the tank sender was sending a very low reading.

Could the lack of boost and go be fuel related too? (i.e everything related to the pump, sender and it's wiring in the boot?).

As to why that would trip the TCS I don't know though.

It seems to be 2 unrelated issues, unless someone can prove me wrong.... (and i'm sure they will)

Andrew
 

·
Registered
Joined
·
8,948 Posts
My only hesitation in the Aero was the time it his the overboost switch at 135 in 4th in the Lake District (5 up with loads of camping gear).

Shortly afterwards the wastegate was fixed and the head gasket replaced....It was quick back then though.

I've never driven that quick before or again in my life. Everything arrives so fast.

Andrew.
 

·
Registered
Joined
·
192 Posts
Dunno about your car but on my 2 litre NA ahem 'beast' the senders integral to the pump. Dicky connection, means fuel level drops and the pump cuts out.

That mean on boost the fuel doesn't come out of the injectors thus a violent cut and that woudl cause it to go into limp home mode.

Check the connections. The relay might be playing up as well.

Don't know for sure but it may have a 2 stage relay, basically when toddling along waving to old people and so on the relay acts like a ballast resistor then when you plant it to get the 50 points for hitting that old person the relay trips and the pump gets the fuel battery voltage.

Chris
 

·
Registered
Joined
·
4,215 Posts
Discussion Starter · #11 ·
did the poking around under the bonnet thing
and two things
the vac hose to the fuel reg crumbled in my hands
quick on with the samco and acouple of zip ties..
and as I was doing this the big hose for the rocker cover ventilation came away as well ..
zip tied that back in place ..

tonight no hesitation ..so fingers crossed !
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top