Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
When pressing the lock or unlock buttons on my 2005 9-3 Aero convertible I can see that the indicators flash as if the fob is recognised, but no lock or unlock happens with the doors. The previous owner provided a non-Saab additional remote which does work. How can I get the Saab key fob to work?
 

·
Administrator
Joined
·
5,122 Posts
there are no other fobs that can be married to the car,they have to be oe to be inserted in the ism to start the car..

pls post a pic of other fob..
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Here's a video of my situation - ideas welcome!

One thought about this, which I have discovered while recording this is that one of the DTCs shown by Tech 2 is Door Ajar BCM B2991 05 - would make the key fob respond the way it does? If so, any tips on how to fix it would be gratefully received. Also shown is PDM B3130 02 Lock Motors Common Short to Ground. Video showing Tech 2 DTCs:
 

·
Registered
Joined
·
5 Posts
When pressing the lock or unlock buttons on my 2005 9-3 Aero convertible I can see that the indicators flash as if the fob is recognised, but no lock or unlock happens with the doors. The previous owner provided a non-Saab additional remote which does work. How can I get the Saab key fob to work?
The most likely reason this is doing this is because someone has bypassed the central locking system so the aftermarket remote will work, why they did that? whos knows, they could have been trying to get around a problem with the car. It's probably why you have the lock motor common code as they have used that for the aftermarket deal. Is the door ajar lamp on? The OEM remotes have two separate functions and work independently of each other, one is the starting/running function and the other is central locking. Did you clear then run the DTC check? If you look at the wiring/modules, I would have to guess you will find the were they altered the factory systems. Again my guess would be the previous owner has altered the OEM system.
 
1 - 4 of 4 Posts
Top