Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 4 of 4 Posts

·
Registered
Joined
·
411 Posts
Discussion Starter · #1 ·
I've been having recurrent problems with dirt appearing on the ABS sensors on both front wheels of my '93 CD. I clean them and it's 2-3 months of ABS-dashlight-free motoring. Then ... DING! On it comes, the illumunation of the light is totally random, not being associated with any particular action such as touching the brake pedal.
I clean both sensors of their newly acquired spot of gunk and everything's fine again. For 2-3 months. The dirt accumulates in a short, narrow strip in the centre of the sensor face, possibly due to electro-magnetic attraction.
My query is what IS this gunk, and how is it getting into where the toothed wheel, which reacts with the sensor, is in the hub? How can I stop it?
Anyone got any ideas or theories??
 

·
Registered
Joined
·
231 Posts
I would assume brake dust as well, but it's curious that this happens so frequently.

My brake dust just seems content to form a greasy film on the front wheels. I haven't had any sensor problems since I got this car 14 months ago (probably will now)!. Harder brake pads needed perhaps?
 

·
Registered
Joined
·
411 Posts
Discussion Starter · #4 ·
Thanks for the feed-back. I, too, think that it is brake dust. But isn't the sensor/toothed-wheel assembly sealed off from this? Surely it would be?
But it IS a SAAB, so .... mmmm.
Looks like I might have to take a long, careful look at the hub. All I need for that is a good diagram of the hub components.
Any suggestions as to where I can get one? There's nothing like that in the Haynes manual.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top