Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2,041 Posts
Discussion Starter · #1 ·
Wonder if anyone can assist with a problem on my son's car. Appears to have gone into limp mode - engine management light is on. Pulled some fault codes, the first being throttle position sensor which has been replaced. He has also replaced the air tube from the filter to the throttle body as old one was split. Disconnected the battery to clear ECU but fault persists.
Lumpy on idle, fluffs on pick up but will rev if pushed and no power when driven. New plugs Sunday - no change. Old ones weren't particularly sooty but only returning 23mpg.
Appears to have air mass meter, MAP sensor, cam and crank sensors.
Any thoughts as to where to look first - O2 sensor? air mass meter?
Any suggestions welcome.
Thanks
Mike
 

·
Registered
Joined
·
2,041 Posts
Discussion Starter · #3 ·
Thanks Paul
New plugs, new throttle position sensor, new camshaft sensor - still idles lumpy and no power and engine management light on.
Any suggestions welcome that don't involve a cliff at this stage.
Thanks
Mike
 

·
Registered
Joined
·
2,041 Posts
Discussion Starter · #4 ·
Some issues now resolved - will start and idle and rev but still not its old self. Cat is very rattly - could this be disintegrating and causing blockage?
Codes now showing a knock sensor fault which is a new one as before was cam sensor which has been replaced.
Does anyone know if the throttle postion senor needs calibrating after replacement or is set up straight away?
Thanks
Mike
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top