Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,676 Posts
Discussion Starter #1
Anybody know the correct orientation of the three wires coming from the Trionic crank sensor? I was assuming -as the connector is the same for Trionic and DI - that the middle wire was the crank signal, with 12V supply and ground on either side, just like on the DI and EZK Hall effect crank sensors, but connected like that, and no matter if the +12V wire is on the left and the ground on the right or vice versa, I get battery voltage on the signal lead, dropping down to ~8V when cranking (interestingly, the blue lead from the DI ECU to the LH ECU containing the ignition pulse, behaves exactly the same - only it's correct here and not for the crank sensor, which should be 5V with key in running position, then negative pulse when engine is cranking, right?

TIA,
Eric
 

·
Registered
Joined
·
8,216 Posts
As far as I can see, this is a passive inductive sensor, so doesn't need +12V. Pin 1 is the signal (7-10Vac at idle, 15-20Vac at full speed). Pin 2 is ground and pin 3 is the cable shield (pins 2 and 3 are both connected to ground near the ECU).

The parts are not the same between Trionic and DI. You might want to make sure the 20Vac maximum will not damage the DI input.
 

·
Registered
Joined
·
1,676 Posts
Discussion Starter #3
Thanks Bill - just got off the phone with Frank to see whether he's sure the DI was working with this set up, and he admits he's probably mistaken - seems that car went through a few different configurations which made things a bit confusing for him...

So now it's either get the correct crank sensor and 900 EZK oil pump cover (though I shudder to think about having to unbolt the present set up and removing stuff from the pulley side of the engine again, what with the 2" clearance to the firewall and the scratches on my hands and forearms only just about gone by now...
) or **** the DI unit (might be damaged, I get some strange things out of it...) and go to either Trionic 5.X or some form of aftermarket engine management... For now, the regular igntion set up is back on so I can take the take in for its MOT next week, which is overdue anyways...
 

·
Registered
Joined
·
1,676 Posts
Discussion Starter #4
Yer what? I can't write 'to55' (as in ' ~ out the window')? Now why 'to55er' is in the self-correcting non-PC words list I can imagine, but this seemed quite innocent - or does aforementioned word have a universally known-about, less-decent connotation that I don't know about?

Oh well- at least here's 1,000 TTE forum postings!
 
1 - 4 of 4 Posts
Top