Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 12 of 12 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter · #1 ·
Hello guys (and girls),

It's been a while since I've posted here, but in that time, my transmission got fixed (turns out it was a $2 governor seal that was causing all kinds of problems...), and my car is running very nicely.

My question is this: I've got a 1990 9000i automatic, with the ZF4HP18 transmission. The shifting is fine, not too jerky or rough. Plus, the gear selection works perfectly too. The only problem I have is this moderate whine, which I assume is my transmission...

Ever since my transmission cooler line rusted through and leaked (and I had it repaired with some hydraulic hose) about a year ago, it's been making this whining noise. The noise sounds like a "woooooooop", and happens only in first gear, and disappears when it shifts into 2nd. I think it sounds a bit like a distant police siren, actually... It doesn't occur in any other gear; ONLY when I'm in 1st gear, and even then, only about halfway towards the 1-2 shift.

So? what do you think? I've heard that "Lubegard Red" might work, but I'd be wary of putting anything into my transmission... Is this something I can live with, or a sign of impending doom?

cheers!
 

·
Registered
Joined
·
2,886 Posts
There was a saab notice about autobox whine and they said that putting lubegard into the box was acceptable.

As far as I know its covered on the townsend imports site

I keep meaning to get some lubegard put into my autobox.

Steve
 

·
Registered
Joined
·
129 Posts
Discussion Starter · #4 ·
Yep, I checked the fluid... It's at the proper level (I checked it while running, while hot) and it's right up to the 80C mark. The fluid is nice and pink, and smells... well, transmission fluid doesn't smell nice to begin with, but it certainly didn't smell burnt.

I'm thinking maybe it has something to do with the fact that I had one transmission cooler line replaced with hydraulic hose... The hose has to be at least twice the diameter of the original cooler line, so would that result in some lower pressure coming in or going out of the transmission? It's the line on the left-hand side of the car (driver's side, since it's LHD).

I also noticed a lot of Honda Accord automatics of that vintage make the same kind of noise when accelerating from a dead stop. The noise stops when it shifts into 2nd gear.

I did read about the lubegard thing, but the bulletin was in regards to the 2-3 groaning noise upon upshift. This noise is only in first gear. Hmm...

any thoughts?
 

·
Registered
Joined
·
81 Posts
Rocky, I don't know a solution but I just thought I'd say that I have the exact same problem with my '89 9000. It's been like that since I got it 9 months ago, looking at the service history, there hasnt been any fiddling with the box apart from fluid changes.

I don't have any other probs with the transmission apart from some slightly jerky shifts from a cold start. The sireny noise did freak me out a bit at first tho - kept thinking the cops were after me! - but I just got used to it in the end. Still, if you work out how to make it go away, I'd love to hear how.
 

·
Registered
Joined
·
230 Posts
Rocky,
Hi form australia.
I'd start by trying to use a hydraulic line of similar size to the one replaced, as the pressure problem could be a clue? I am only guessing, but may-be worth a try, then you are starting with a similar environment to original. It would certainly rule out this as the cause.
If it continues, it could be slight damage to the first gear cogs due to fluid loss whilst cooler line was out.
Cheers, good luck.
Chris
 

·
Registered
Joined
·
129 Posts
Discussion Starter · #7 ·
Hmm, good thoughts...

It's nice to know I'm not alone in experiencing this kind of problem! Although it's not so much a "problem" as it is just a minor concern, but oh well.

The hydraulic line is something I was considering as a possible cause of the noise, since the transmission made no noise before the cooler line was replaced. However, other people have replaced their cooler lines with similar materials, and reported nothing in the way of abnormal noises...

I should add that it makes the noise in first gear, regardless of whether I'm in D or position 1. Also, the noise occurs in reverse as well. Maybe I'm being paranoid or obsessive? Well, I've read so many accounts of the autoboxes going bad that I figure it's better to be safe than sorry... Personally, I'm prepared to just ignore it, since it shifts just fine, and the ATF is fresh and free of debris.

I'll keep you guys posted...

thanks for the ideas though!

 

·
Registered
Joined
·
1,664 Posts
Here is my twopenneth,My 92 2.3Auto developed a whine in all lower gears,changed oil with limited inprovement.In the end I took it to an auto shop, who found the pump in the box had a crack between two teeth,an apparently common occurence.Cost me about £250 to put right.
Mike
 

·
Registered
Joined
·
129 Posts
Discussion Starter · #9 ·
Hmm, I think MikeH might be on to something here...

I know of a really good auto transmission repair shop nearby (they diagnosed and fixed my governor seals very quickly this summmer), but I'm a little wary of spending upwards of a few hundred bucks on it... Especially if it's not a serious problem and won't get worse. So far, I've had the whine for over a year now, and it hasn't gotten any worse at all. Do you think this is something I can leave until I have saved up enough money?



cheers!
 

·
Registered
Joined
·
2,886 Posts
My 2.3 has had the 1-2 whine for over 30,000 miles and apart from that its not shown any other real problems... I guess its one of those things that if you are having other things done its probably worth getting done at the same time.

Steve
 

·
Registered
Joined
·
129 Posts
Discussion Starter · #12 ·
Ok, thanks guys!

It looks like I'll just leave it alone for now and get it looked at later on. It's great to have some good advice like this. If it weren't for the atlantic ocean in the way, I'd invite you guys for a beer!



take care
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top