Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 13 of 13 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter · #1 ·
my 1990 2.0t, has a strange noise from the engine compartment, it only does it when engine is running over 2500 rpm, (either under load or not undewr load), and the best way i can describe it is a metalic rattle noise, tried to locate it and it seems to be coming from the drivers side (uk) back of the engine, near the alternator, and p/s pump location, it's been there a while now, and there has been no loss in performance, just irritating.

any advice greatly appreciated

all the best

tommy
 

·
Registered
Joined
·
328 Posts
do you have the noise at startup when it's cold?

I have a metallic almost chirping sound from the place you describe but it goes when it warms up. I was told it could be the engine mountings. But I'm waiting for the next service in a fortnight to check it out.
 

·
Registered
Joined
·
155 Posts
Discussion Starter · #3 ·
its there all the time, cold, warm, it dont matter, its really wierd, and irritating as it makes you worry is it somthing serious, one thing i have noticed though, that say youre accelerating in 1st, the noise comes in at about 2500 rpm, the moment i take my foot off the accelerator, the noise dissapers, until im in second and the rpm's get to 2500-3500, and it returns. its really, starting to bug me now, but before i take it in to be looked at, i hoped that some of the other saab drivers out there might have had the same problems, by the way engine has 149000 on clock, recently had a head gasket job, but the noise was there a long time before head work was done, so i dont think they are related.

cheers

tommy
 

·
Registered
Joined
·
1,664 Posts
Tommy,I am afraid your noise sounds like the timing chain,it may be nothing more than a faulty tensioner but needs checking,if the chain breaks you are in for spending mega bucks,The only doubt I have is that you said you have had work done on the head,a timing chain fault should have been picked up then.
 

·
Registered
Joined
·
763 Posts
Also, try checking the serpentine belt tensioner-pulley compressor, the rubber/aly pivot joint of compressor base fails and it becomes loose/noisy within the housing bracket. Take belt side wheel arch lining off and all will be visible. If possible, take belt off and check both idler pulleys, if rough, replace.
 

·
Registered
Joined
·
243 Posts
I've got this too, have you tried tapping the little front exhaust box (where the catalyst would be on later models) to see if the baffle has come loose - I have, and it has, but being an automotive engineer/mechanic type person have never got round to replacing it as I'm too busy with other cars. Timing chain wear has slightly different symptoms to what you've described (and yes I changed the timing chain, guides and tensioner when I bought the car 6 months ago and the rattle still persists) I'd say exhaust....
 

·
Registered
Joined
·
155 Posts
Discussion Starter · #7 ·
thanks foe the feedback so far, i am about to check the timing chain in the next few days, but am unsure what to look out for, also noticed that the noise only appears when driving forward, (not whilst reversing), if it is the chain and other related parts, how much is this to replace. i havent tried the 1st silencer box, but will later today.

once again thanks for the feedback

tommy
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top