Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,886 Posts
Discussion Starter · #1 ·
Car starts and idles fine at cold. Sometimes when its just starting to warm up the revs at idle drop from about 800 to 400 and then bounce back up again.

Last night drove down the M42/M5 no problems at all and drove down about 1 mile of road at 50mph. Pulled up at the first set of lights.. engine revs dropped to 400, headlights dimmed, engine speeded up to 900 , lights brightened, CD went CLICK and then I pulled away.

Next set of lights the same thing... engine almost stalled several times as I sat there.. had to nurse the throttle to keep it going. Set off from those lights, got to the roundabout... everything fine, and behaved itself all the way home (which included a stop at the store for some milk).

So is this typical of a clogged idle valve or something else?

Steve
 

·
Registered
Joined
·
2,886 Posts
Discussion Starter · #4 ·
Well I finally got round to doing it. Followed the instructions from Saab9000.com. It didn't help that the swede who put my car together put all the jubilee clips on so that none of the screw heads were accessable on the valve. But with some twisting I got it out and it was filthy.

So I cleaned it out, cleaned the butterfly valve in the throttle body and put it all back together. One thing I did find annoying was I dropped the power lead and it vanished somewhere behind the engine but I eventually found it.

I checked all the hoses and tightened up all the clips I could find.

Started fine - idle is rock solid now.

I also found a very good road for an adapation run so I have done that as well.

Steve
 

·
Registered
Joined
·
1,749 Posts
Originally posted by scminks:
[qb]try cleaning it out with some spray carb cleaner.dont be tempted to lubricate it after though! [/qb][/b]
Eh oh!
Why not? Can't remember if I did or not to be honest. I know my idle is rubbish though... no better and possibly worse. Hmm, wish I could remember if i gave it a blast of WD...
 

·
Registered
Joined
·
243 Posts
hi all ,
just to clarify is the AIC valve the little round one bolted onto the front of the inlet manifold?
if so what is the best way to clean it?
the problem that i have is that i get erratic idle when warm but also when i am in gear and driving normally sometimes the car judders like it is misfiring and then runs normally againoh its a 1990 cd carlsson, done 96000 miles ( If that helps )
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top