Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,673 Posts
Discussion Starter · #1 ·
Whats causing condensation inside?,now this is happening when I'm bone dry.

Now I could see this happening when you get soaked and you get inside,and the windows steam up untill the heat gets up then it disapears,but this is all the time dry/wet.

Has anyone got any clues to this as it's doin my head in,what I should say it happens usualy at night when it's getting cold,cheers.
 

·
Registered
Joined
·
14,305 Posts
Other possibilities inlcude:

Recirc vent flap stuck on recirc. The easy way to test this is to set the blower on full, step outside, shutting all doors/windows and see if there's air (audibily) blasting out of the vents at the back either side of the rear screen.

Condensate drain from the A/C blocked.

If it is the matrix, you'll also notice an antifreeze-type smell, which will be worse when the engine is warm.

Good luck!
 

·
Registered
Joined
·
1,673 Posts
Discussion Starter · #4 ·
Cheers guy's....but Bubbles I don't have a/c and there's no smell/loss of coolant anywhere I forgot to mention that.

But do I still do the same test as described although I don't have a/c?,do I have still have a "drain" for the system although it's not a/c.

And if so where is it?
 

·
Registered
Joined
·
1,749 Posts
The other possible problem is a leak.. I mean a body leak, letting water in. Believe me, I've had a lot of leaking cars and they all have that problem. Especially bad on cold sunny winter mornings, when the sun heats the inside of the car but the external temp is cool. Running the heaters just makes more of a sauna effect . Even a small leak creating a bit of damp carpet will cause this.

I have been wondering about car dehumidifiers...
 

·
Registered
Joined
·
126 Posts
Heh, already considered posting topic on thistheme naming it 'Winter Issues' as it tends to get worse with upcoming winter, but here it (the topic) alredy is...

I HAD the same problem on my CS'1992 till yesterday. The steam-up starts after some 20min drive and goes worse until complete mist-up ("tank mode on" - visiblity 0). The symptoms identical of forgeting AC into recirculation mode... And... yes, that's it! I tryed to change recirculation mode - and for my (not) surprise, no blower sound change at all... (Should be, as much as noticable change in blower sound, as I remember from previous times.) Thus, knowing that the recirculation flap is most likely stuck, and wanting not to bug with it on my own, I drove directly to SAAB garage. I asked them just to make the diagnostic, to see if flap motor is ok/not, or if some connector is just gets loose, or if flap is just stuck.

They unscrewed false bulkheads cover and removed salon air filter (The flap is directy under it. Btw, this filter could be cause of mist-up if somehow gets more wet than usualy). Then we tryed the mode-change slightly helping the flap to move with hand. And, it did! It works fine now. No more misting, more fresh air in the salon, etc.

This all takes some 15-20min, and £0 from me

Cheers
Dzintars 9000CS23T
 

·
Registered
Joined
·
2,599 Posts
Thanks for the info Nufis - will try this myself. I have two CSE's one steams up (unless aircon switched on) and one doesnt steam up at all. Interestingly the one that steams up makes no noise change when recirc switched on and off and the amount of air out of the back window vents seems to be exactly the same - and quite alot (not checked the car that doesnt steam up yet) so I was thinking that my recirc vent may be stuck open - which wouldnt explain the steam on the windows
 
1 - 7 of 7 Posts
Top