Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 12 of 12 Posts

·
Registered
Joined
·
227 Posts
Discussion Starter · #1 ·
My speedo sometimes works and sometimes doesnt. I fear the problem is electrical rather than anything else - but I have no idea where to start.
Any ideas??

Stu
 

·
Registered
Joined
·
8,216 Posts
Look for the speed sensor down by the differential on the gearbox. There's an electrical cable coming out of it leading to a connector. Try unplugging and re-plugging the connector (it's one of those locking types used all over the 9000). If that fixes it temporarily, you probably have corrosion at the connector. This happened on my '96 Aero when it was just three years and 120K miles old.

The other possibility is mechanical - there is a nylon gear that drives the sensor and it can give intermittent problems before it gives up completely. Apparently, this is quite common. I'll leave it to others with experience of this to advise you, but it can be replaced quite easily and isn't expensive.
 

·
Registered
Joined
·
4,215 Posts
sorry bill but I had the nylon speedo drive gear go...it meant a gearbox out and re-build job..
ouch!! £1200 squid later to replace a gear wheel costing 50p..
But I really do not think it is this problem though..when it fails the speedo stops working completely..no info to the brain and brain gets confused into limp mode and the only way to de-confuse it is to replace gear wheel
btw if you are replacing the sensor it is held into place by something like 27 torx screw.. a 25 will not do and will mangle the inside (personal experience here)It is worth buying one especially
(I could be wrong about the size it is worth checking with your local saab dealership)
good luck !
 

·
Registered
Joined
·
8,216 Posts
<<GULP!>>

Wow! I've definitely heard of people replacing the gear in ten minutes. I assume there are two gears - one on the sensor and one in the gearbox.

Come to think of it (and why didn't I before?), the previous owner of my new (to me) '95 CSE manual claimed the gearbox was replaced with a recon unit by a Saab dealer 1000-odd miles ago for just this problem. They said it would either be a very cheap fix or a very expensive one. It turned out to be the expensive one...

He said the symptom was that the speedo stopped working completely. I believe his story as he appeared to know nothing mechanically about the car and I certainly don't believe he could have concocted such a plausible scenario.
 

·
Registered
Joined
·
227 Posts
Discussion Starter · #7 ·
Thanks guys,
Been out in the car today for a long run. The speedo either works or doesnt. When it works it is perfect - no judder, Cruise works fine. When it doesn't - Nothing at all. Engine runs fine in both instances.
I'd like to get it sorted soon before I become rst99 got gatsoed . Sorry for being stupid but do I find the sensor in from the top or under the car.
Thanks again
 

·
Registered
Joined
·
227 Posts
Discussion Starter · #9 ·
I have found cable coming from the top of the gearbox. It comes from a ~25mm plastic hex thing and goes up via a connector to the back of the throttle housing.
Is this it??
 

·
Registered
Joined
·
3,892 Posts
Glad I'm not the only one to have the 50p plastic speedo drive ring break on the diff and have to shell out £1000+ to fix it.......
Mind you it did mean that I ended up with a LSD because of it..
 
1 - 12 of 12 Posts
Top