Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 2 of 2 Posts

·
Registered
Joined
·
14,305 Posts
Discussion Starter · #1 ·
Some of you may know I've been chasing a problem with variable perfomance on my 9k (MY93 Trionic)for some time now (over a year!). We've tried allsorts... ECU remaps, various different hardware changes etc, all to no avail. One day it'll go like stink, the other it's comparatively gutless. Most recently I've replaced the fuel filter and put a high flow pump in.

Yesterday I happened to have access to Tech 2, and this is what I found:



No check engine light, I cleared the code, re-started and it didn't re-appear again whilst stationary. I took a look at the timing info:


The timing doesn't look good on idle, and it was hunting somewhat.

It's driveability over the last few days, especially at low revs, has become really bad- very kangaroo-ish. Yet all of a sudden yesterday with this I was hitting 1.7bar on WOT and going like a scalded cat.

So, my theory is that the CPS has been variably "ill" for some time, but not ill enough to cause a check engine fault. Does this sound plausible?
 

·
Registered
Joined
·
202 Posts
You've cleared the code. So drive around with it for a week or so and check for the code again. Either that or just replace the little ****** with a new CPS straight away.

Hope your find leads you to a cure for your problem. No such luck for me. Tried a new CPS on Friday (having already swapped pretty much everything else), but still no joy. A new set of injectors are next, as one spark plug keeps going black after about a week or two.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top