Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Howdy Saab owners,

About 3 months ago I had engine codes and misfire on cylinder 3. Replaced the coil pack and all running good.

But in the last week, when I accelerate (either at low speed or when on the high way) I get a shudder which seems like misfire. No engine lights on, but ran and OBCD and showed 4 misfires. Accelerating slowly is fine, but accelerating at a normal or aggressive manner is impossible.

Will change out the air filter (2 years) and the fuel filter (never replaced) and add a valve cleaner to the next tank of gas. Any other suggestions before I spend $300 to replace the remaining coil packs? Hate to replace them and find that it doesn't fix the problem.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
Try changing your spark plugs. I use NGK BCPR7ES11's. My 9-5 eats plugs every 3k miles or so.
thanks kdwornick - I changed them the first time back in 2009 when I purchased the car (2006 model) and again wbout 18 mo ago at 95k miles in 2021. Interesting that you replace so frequently? How does your car 'eat plugs?'

Added an octane enhancer and filled up with 93 octane, definitely peppier than before! Pushed it hard and got a misfire code on cylinder 4 - runs fine if I don't push it. Likely purchase the new coldpacks in Sept as they are original and car is 15-16 years old now.
 

·
Registered
2001 Saab 9-5 estate 2.0t silver
Joined
·
5 Posts
Howdy Saab owners,

About 3 months ago I had engine codes and misfire on cylinder 3. Replaced the coil pack and all running good.

But in the last week, when I accelerate (either at low speed or when on the high way) I get a shudder which seems like misfire. No engine lights on, but ran and OBCD and showed 4 misfires. Accelerating slowly is fine, but accelerating at a normal or aggressive manner is impossible.

Will change out the air filter (2 years) and the fuel filter (never replaced) and add a valve cleaner to the next tank of gas. Any other suggestions before I spend $300 to replace the remaining coil packs? Hate to replace them and find that it doesn't fix the problem.
thanks kdwornick - I changed them the first time back in 2009 when I purchased the car (2006 model) and again wbout 18 mo ago at 95k miles in 2021. Interesting that you replace so frequently? How does your car 'eat plugs?'

Added an octane enhancer and filled up with 93 octane, definitely peppier than before! Pushed it hard and got a misfire code on cylinder 4 - runs fine if I don't push it. Likely purchase the new coldpacks in Sept as they are original and car is 15-16 years old now.
You've probably checked this already but has the Limp Home mode been activated? My 9-5 would start and run OK but if I tried to accelerate above 2000rpm, the car would shudder until I backed off the accelerator and then push the pedal down gently. Loads of advice on Youtube on how to check and reset it. Good luck
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
You've probably checked this already but has the Limp Home mode been activated? My 9-5 would start and run OK but if I tried to accelerate above 2000rpm, the car would shudder until I backed off the accelerator and then push the pedal down gently. Loads of advice on Youtube on how to check and reset it. Good luck
thanks Bluetarget - no I never got into limp mode, nothing that severe. And even struggled to get the check engine light on. But I did swap out the three remaining cold packs and the power is back at all speeds/rpm's.

appreciate the feedback :)
 
1 - 5 of 5 Posts
Top