Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
could and one please help me,,,, I've recently had changed my front right suspension strut. the same day after the suspension was re.assembled three warning messages came on the dashboard ABS FAILER, TRACTION CONTROL FAILER, AND STABILITY FAILER. before the suspension was taken apart the ABS sensor was disconnected on the suspension strut and reconnected when all work was done.... garages are trying to charge me £130 for a new ABS sensor plus labour. other people are saying the ECU just needs reseting ive disconnected the battery for 12 HOURS but still the same..........................

many thanks if I get the right answer
 

·
Super Moderator
Joined
·
3,056 Posts
Re: saab 93 aero 2007

Hello and a warm welcome aboard the good ship saabscene leesmith.
When you say you disconnected the ABS sensor on the strut . Do you mean you pulled the plug apart , or just remove the plug from the mounting bracket ?
Cos I'm sure when I did mine I just removed the mounting bracket . ( a bit hazey is my memory , but I can't remember disconnecting any plug ) . Have thease garages atchually read the fault codes ? .
I would fist check the plug and make sure there's no corrosion on any of the pins . And no wires are broken or pinched .
I shall stick this in the relevant workshop section
Also are you doing the other front strut as well , should be done in pairs .
 

·
Registered
Joined
·
1,169 Posts
Where abouts are you and which specific model do you have?

High probability the wiring has been messed with during the suspension work and/or the steering angle sensor needs calibration.

Need the Tech2 codes for correct diagnosis.
 
1 - 3 of 3 Posts
Top