Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all, I'm new to saabs and this site, Sorry first post and i'm already after advice.

when i brought my 93 the MIL was on, i plugged this into a reader which said 0400 low flow, egr, the car run fine with the light on but i had the egr changed anyway.

after having the egr changed there is a mis fire from around 1500 - 2500 revs it only mis fires when driving normally, ie you have a harsh right foot or put your foot down the car is fine its only when light aclleration is used!

i have taken it back to the garage and they say they have changed the egr again and cleaned out the mainfold and maf sensor, tho the car is still mis firing this time it seems to be a little higher in the rev range 2000 - 2500.

if you hold the car at the misfire it wil continue to mis fore untill you rev past it.

I have tried long trips down the Mway at 2500 revs and still the same.

I really could do with some advice!

many thanks
lee
 

·
Registered
Joined
·
21 Posts
I would have my doubts as to whether the garage have actaully changed the EGR valve. This sounds like classic EGR value symptoms. If you know the garage well, I will eat my words, but I know from experience that some garages simply take the EGR out, wash it in parafin and put the same one back. They are not difficut to replace and I would have a go at it myself if I was you. (they are at the back of the engine on the passenger side, high up - you can easily get at it. You can pick up a brand new one for about £70)
 
1 - 2 of 2 Posts
Top