Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Dear Reader,

My mother in law's (really) Saab 9000 does not start ok when hot.


At cold it starts and runs perfectly well but hot it starts instantly and then dies within seconds.
Starting'r up again and then trying to drive away immediately I find there is no power at all and the engine dies again.

It is possible to keep it running a bit longer by fiddling with the accelerator pedal but eventually it dies again.

This goes on for some 5-10 times, trying revving it up to keep it running but it still dies and then, suddenly, it runs perfectly after hitting the 5000 rpm mark once...

The first time this happened, it turned out the exhaust had a leak close to the Labda- sensor. Renewing the exhaust removed the problem for over a year. Now it is back yet the exhaust is perfectly air tight... Any suggestions?

Thanks in advance and best regards,

Matthijs Meulenbelt
The Netherlands
more dedicated to old english cars
 

·
Registered
Joined
·
1,359 Posts
check the post (starting prob with half tank) the iac can cause this problem it was this which caused me to clean it the first time so give it a good clean out and check that the hoses are ok and not drawing air
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I found the cure:
It turned out the temp sensor for the fifth injector is faulty. Disconnected. Problem solved.
I will replace the sensor if problems occur in the winter.

Matt
 
1 - 3 of 3 Posts
Top