Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 3 of 3 Posts

·
Registered
Joined
·
706 Posts
Discussion Starter · #1 ·
I have now placed one of the poly bushes into the top torque arm.
Getting the old one out took 25 mins, getting the new one in took 2.5 hours


As you can see from the image they are not exactly the same size wise.

After dealing with that fiasco I'm wondering whether or not to get someone else to do the other torque arm bush as it would appear that it is all atached to the alternator etc.

Hopefully tomorrow I will get the other hydraulic engine mount fitted and the gearbox mount.

Skiddins

 

·
Registered
Joined
·
706 Posts
Discussion Starter · #2 ·
Right I have now fitted a new rear hydraulic mount, gerarbox mount and the rear anti-roll bar bushes.

One small question, when I was trying to undo the 16mm bolt that holds the engine onto the engine mount I constructed a long extension, couple of UJ's and about 4 extensions

Trouble is it appeared to fasll agaisnt something when I was manouvering it and sparks flew.
As I was half under the car I could not see exactly what it touched but it looks like it made contact with the connector block that is directly above the rear engine mount (about 5 inches up)

Does anyone know what these wires do etc?

The car starts and everything works, but I have now noticed that every now and again the idle dips down to about 600 rpm.

Could my electrical cockup have something to do with it?

Skiddins
 

·
Registered
Joined
·
2,277 Posts
Hi Skiddins,

Havn't got special knowledge of this area, but the alternator is directly connected to the battery... so, if you've touched the exposed terminal of the alternator and any metal part of the car then sparks will be the result.

Shouldn't have damaged anything except your pride though!

Nick.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top