Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 3 of 3 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hi my car is a 1988 2.0L turbo CD which has covered 180K KM. Going to work my car was misfiring really bad, even when hot. When idling I could hear a noise from the boot. The next day it wouldn't start as no petrol was getting through so I suspected the fuel pump, however this seems to be working OK. The pump relay and system relay seem to working OK too. The car won't start unless I ground the earth terminal at the back of the pump relay. What do you think the problem is? Dirty earth or maybe the pump after all? Or perhaps the ECU?
 

·
Banned
Joined
·
693 Posts
Originally posted by Eddie Boy1:
[qb]Hi my car is a 1988 2.0L turbo CD which has covered 180K KM. Going to work my car was misfiring really bad, even when hot. When idling I could hear a noise from the boot.  The next day it wouldn't start as no petrol was getting through so I suspected the fuel pump, however this seems to be working OK. The pump relay and system relay seem to working OK too. The car won't start unless I ground the earth terminal at the back of the pump relay.  What do you think the problem is? Dirty earth or maybe the pump
after all? Or perhaps the ECU?  
       [/qb][/b]
Oh S**T - finger trouble agane........

What I MEANT to say (before sending) was, if grounding the earth terminal at the back of the pump relay solves the problem, if it is really an earth terminal it is meant to be grounded anyway, so there's the cause of your trouble - as you say, dirty earth. Then again, if it's NOT really an earth terminal, you will need to look elsewhere. Hope this helps.

BOF
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top