Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My 16T is pinging under boost. As soon as a wee bit of boost is developed (i.e 1/3 orange or so) the engine shudders and the boost is reduced. Last night I did a long distance trip from Gladstone to Brisbane and the problem was so bad that I was not able to overtake cars safely. The problem seems more apparent in 5th gear. The problem is pinging and not a misfire because I can hear the pinging.

I have a new set of properly gapped NGKs, new ignition cables, rotor and cap. There are no vacuum leaks to my knowledge and the fuel is 98 RON.

Any suggestions?
 

·
Registered
Joined
·
139 Posts
Is your fuelling good? Pressure, as well as mixture? This can be checked, along with a check for boost enrichening by a garage with emissions equipment.

How's your timing?

Another place to look is the vacuum advance capsule on the side of the distributor. At idle, remove the vacuum line from the intake manifold (and place a finger over the exposed port). Suck/blow down the vacuum hose. If there is no resistance, the module is broken. If there is resistance and the engine pitch changes, it would appear to be fine.

Finally, compression ... are all cylinders roughly producing the same figure? What pressures do you get?
 

·
Registered
Joined
·
1 Posts
My 16T is pinging under boost. As soon as a wee bit of boost is developed (i.e 1/3 orange or so) the engine shudders and the boost is reduced. Last night I did a long distance trip from Gladstone to Brisbane and the problem was so bad that I was not able to overtake cars safely. The problem seems more apparent in 5th gear. The problem is pinging and not a misfire because I can hear the pinging.

I have a new set of properly gapped NGKs, new ignition cables, rotor and cap. There are no vacuum leaks to my knowledge and the fuel is 98 RON.

Any suggestions?[/b]
Another thing to check is the air hose just before the throttle body. It becomes loose and tends to come off as soon as it builds pressure. What kind of ignition cables r u using? My apc was detecting knocking with my 2.5 years old magnecors even at 1/3 yellow boost. As soon as I replaced them with a new set of bougicords I was back to the red. Had read somewhere that our Saabs for some awkward reason, prefer bougicords. This came out to be so true… Had tried almost everything the past 2months to cure my interminent boost issues.
 
1 - 3 of 3 Posts
Top