Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 5 of 5 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hi all.Can anyone help with this one,Iv a 04 93 tid 150,the other day it just lost all power,reved ok but wouldnt pull away,slight smell of diesel exhaust,then after a mile off going at 2mph it went ok,took it to the dealer,couldnt find anythin wrong,said it could be the partical filter regenerating itself on the exahust recyling!! and says it does that when you only do short distances,I thought it was a load of the old bull,and thought it was the egr valve,has anyone heard of this happening? good forun by the way,keep it up.cheers
 

·
Registered
Joined
·
3 Posts
I'm driving an '05 93 120 at 47k. I am having a similar prob. I've been down the EGR route, cleaned and then replaced following complete loss of power and thought things were OK. However I began to experience slight loss of power (judder through the accelerator - hesitantcy??) between 1200 and 1900revs following this supposed fix.

The Dealer had suggested that particulate filter on exhaust was 'not regenerating itself'. Having had the car back three times to monitor this problem they have said there is no problem and i should look at the grade of fuel I'm using - supermarket versus Shell etc. It's early days and I've not noticed any benefit yet.

What do people think?
 

·
Registered
Joined
·
25 Posts
having very similar issue myself and the garage have suggested it could be the particle filter carrying out a regeneration but it does seem to happen too often (can be over a distance of only a few hundred miles) to be this - no other explanation is forthcoming.
 

·
Registered
Joined
·
3 Posts
I have just had exactly the same problem. Lack of low end power for a couple of days and then on pops the engine light. Calls AA, who got fault code, but it was dealer code. Took it to dealer, who tell me its the particle filter.
He took it round the back and did a computer regeneration, which was basically rev the tits off it for 20 mins, get it very hot and drive it up the road for another 10 mins. It solved the problem and now runs like a dream.
But what I did get from the experience was.
The AA man said that this was a common problem with people who drive round town at low revs and never venture on motorways.
But then the Saab engineer also quoted, it is very common with 6 speed cars on motorways. 80mph, under 2000 revs (in my case automatic) and ideally 4000 revs is needed for regeneration.

Hope this answers a few questions

2007 9-3 1.9tid Sportswagon Auto
 

·
Registered
Joined
·
65 Posts
VERY COMMON PROBLEM,SAAB ARE BRINGING OUT A MODIFIED EGR VALVE. CHECK IF ECM SOFTWARE IS UP TO DATE ALSO MAP SENSOR IS CLEAN. OTHER PROBLEMS WITH PARTILE FILTER CLOGGING UP IS SWIRL MANIFOLD LINKAGE FALLING OFF (150BHP).OTHER FAULTS WITH THESE ENGINES ARE BOTTOM PULLEY OUT OF ALIGNMENT AND EVEN CAMBELT JUMPING A COUPLE OF TEETH BREAKING THE ODD ROCKER ARM WITH NO OBVIOUS MISFIRE.
 
1 - 5 of 5 Posts
Top