Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 9 of 9 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1 (Edited)
I was going to investigate the possibility of retrofitting an OEM UHP bluetooth but as the wiring looked tio be far to much trouble I dug out my old Parrot CK3200LS Colour that I removed from my Vectra when I fitted OEM Telephone.

However, having bought the JustCarkits Saab13tel lead and found the Tel1 connector in the left hand console I thought it would be plain sailing but alas no, the Parrot powers up and functions as expected, but does not mute the radio nor can I hear anything from the speaker. I contated JustCarkits and they asked a few pertinent questions regarding the wiring etc but still no real solution.

So I bench tested the lead with a spare speaker connected to the speaker outs from the lead and it works no issues at all. I am now thinking that the Tel1 connector may be an issue, although, it connects power and the Saab microphone and I get the Goodbye message on the parrot when ignition is turned off.

Tel1 Connector pinouts from WIS is below:-


All seems OK but I cannot get the Tel1 connector appart to check that the pins are correctly seated and the pins are very fine and I dont have anything at the moment that will fit the connector so I can buzz out to the radio connnectors.

I know that the mute signal should go to pin 4 on the K16 connector on the radio and that the speaker used is the Left hand door speaker pins 2 & 9 on the K14 connnector.

Anyone else had problems with the Saab13tel cables or the Tel1 connector. My radio is a retrofitted SatNav unit (OEM) and works fine.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #2 (Edited)
I have been in contact again with Justcarkits and (Phillip) advised me that the Mute signal should be between 12V and 5V when not on a call and drop to 0V when calling (Muting).

I bench tested the parrot and found it was 6.8V no call and 0V calling which is right.

I removed the radio from the car and buzzed out the Pin 4 K16 connector down to the Tel1 connector mute again Pin 4 and there was continuity so not the car wiring at fault.

Next step thinking the Satnav (Grundig Delphi) radio was possibly faulty I tested again with the original radio (Fujitsu) and found exactly the same no mute on calling and no sound from the speakers.

I am now at a total loss as to how to get this working. I am going to try the Saab13tel lead in my sons 1.9Tid 2006 on Firday he has fujitsu with 6 disc changer see if it works in his.

Anyone any idea???
 

·
Super Moderator
Joined
·
3,072 Posts
Hello any-mgzt in my own experience, I used the tel-1 wiring harness on my 2008 9-3 with standard infotainment 150 system , for a parrot ck3100
No problem at all just plug and play.
From just car kits
Try it in your sons 9-3 then you should know if it's wiring with in the car or the harness
when you had the original head unit in was there the option on the SID for Bluetooth phone connectivity?
 

·
Registered
Joined
·
46 Posts
Discussion Starter #4
I will see if it works in my sons car Friday and no I did not see anything in the SID as I was sitting in the passenger seat and not looking at the Dash but I will maybe try again today and look
 

·
Registered
Joined
·
46 Posts
Discussion Starter #5
I will see if it works in my sons car Friday and no I did not see anything in the SID as I was sitting in the passenger seat and not looking at the Dash but I will maybe try again today and look
Nothing seen on the SID with Blacktie radio fitted.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #6
I will see if it works in my sons car Friday a
nd no I did not see anything in the SID as I was sitting in the passenger seat and not looking at the Dash but I will maybe try again today and look

I have tried the Saab13tel lead and parrot in my sons 1.9tid and it mutes the radio, sends sound to the speakers and thats it call does not go through but that may be an incompatibility with my phone.

So all in all I am puzzled that it does not work in my car at all.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #7 (Edited)
I now know why it will not work the Satnav radio has no MUTE connection although that does not answer why it did not work with the standard Blacktie radio fitted.


This image has been resized. Click this bar to view the full image.




SATNAV Pinouts Pin 4 K16 is N/C

This image has been resized. Click this bar to view the full image.




Blacktie Radio

School boy error should have looked at those first
 

·
Super Moderator
Joined
·
3,072 Posts
Just my theory this is , but when you put the sat nav radio in , you added it. Via tech 2 ?
Maybe by doing that it removed the mute function .
But as I say that's only my thinking .
 

·
Registered
Joined
·
2 Posts
An old topic but if you're going to attach a bluetooth HF to SAAB NG9-3 Delphi Grundig satnav, you have to connect:

Microphone to K14 connector, pins 4 & 5.
HF voice to K16 connector, pins 7 & 15.
Mute to BCM 707 pin A36.
 
1 - 9 of 9 Posts
Top