Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 3 of 3 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
Drove back from france today and the Temperature Display Reading (Trip Computer Reading) on my 1996 Aero started playing up giving readings from -39 to 60 F.This affected the air conditioning and it would only blow cold air when set to Minimum.Before reaching Calais the readig disappeared and was repaced with four ----.I assume that the outside temperature sensor has gone ?.Has anybody had this problem and is it easy to fix?.
 

·
Registered
Joined
·
60 Posts
I had this problem on a '94 CSE (Temperature Display showing ----) and found out that one of the two wires at the sensor was cut). The sensor was located under the front cowling, behind the bumper, approx. 8" beside the fog light on driver's side (I'm in Canada - for UK cars it may be reversed)
Look under the front air dam, and remove a few 10mm bolts that hold the horizontal plastic cover to allow access to the area behind the bumper.
The temp. sensor is a small, black, round, plastic button shaped object held by a small metal bracket. Because of the close position to the road it is subject to corrosion. It is hard to see the sensor so look for a loose or broken thin wire. I soldered the wire back and it works fine since then. Hope it helps, Leon
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #3 ·
Leon,guess what you were right a wire had broken on the sensor.Tried to get it off and the other wire broke.Got it fixed today and saved the cost of a new sensor.Thanks for your imput.John K.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top