Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 5 of 5 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
Can you lot help me before i go mad
The car is a 9000CS non turbo non DI
The fuel pump is not running
Easy you think....
I have tried another relay, i have put another pump on the boot floor and that doesn't run
There is no 12 volts at the pump
someone suggested the crank sensor which i think is behind the bottom pulley
All suggestions gratefully received
 

·
Registered
Joined
·
552 Posts
I understand that Green Flag check the pump by removing fuses 14 and 30 and linking the contacts, in effect bypassing the relay and putting a permanent live signal to the pump.

If you still don't get power at the pump connectors, then it sounds like a cable break.

If you do get power, then it does sound like one of the inputs to the relay. I'll leave that to someone else, though, I'm afraid.
 

·
Registered
Joined
·
14,305 Posts
Relay info:

The coil is driven from pin 20 of the ECU, and one of the outputs of the main relay, which also feeds the injectors and the ECU itself on pin 9.

So, you could check there's volts on the common blue red to the injectors, or pin 9.

The volts feed to the relay comes off the main distribution strip.

The fuel pump relay feeds the pump on a grey-red wire via fuse 14. With the ignition off, if you use an ohmmeter on both terminals of fuse 14 to determine the resistance to battery -ve. One of them should be open circuit, and the other should have the resistance of the pump on it.

If you don't see a resistance on either terminal, then ground the grey-red wire at the pump end and try again. If you don't see a resistance then, it's a sure bet there's a break in the wiring.

You could also try checking the continuity to earth of the other termianl on the pump.
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #4 ·
hi
Thanks for your suggestions BUT being a cynical old b****r I disconnected the battery last night and left it for 14 hours
reconnected this morning and the alarm threw a complete wobbly so switched alarm off
Bingo heard pump running away i went
PS please don't knick it now you know it's not alarmed
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top