Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi. I have read somewhat similar threads but still struggling to bring my Saab back to life. Please help!
This is what's happening:
1. Car won't start, no crank
2. On check Traction control and stability failures on SID
3. ABS module clicking 3x (inspected inside, looks ok). Tried bridging pins 1-13 2-14 of the ABS module - no go
4. Headlight levelling was making buzzing noise and going little up and down just to stall up. Now both headlights removed.
5. Fuel gauge on zero

I have checked:
Battery ok, wires ok, fuses ok, relays ok, ECU connectors ok, levelling sensors ok, grounds ok, voltage on starter ok.

Can there be anything that is causing ABS Module to fail or The ABS ECU is the problem? Is Tech2 only reasonable way to go for diagnosis?

Please help and advise, maybe some other checks to rule out possible causes?

Ps. Not long ago I have replaced wheel hub with broken ABS sensor wire. Was getting ABS and traction control warning on SID but no problems afterward. The no crank situation came gradually (one month), sometimes I had to turn the ignition on and off to get the engine started but finally ended up with my car dead.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I have done some more checks today.
When key in ON position voltage on 86/85 starter relay (R8) is 9v, relay is not clicking.
When power the solenoid from 87 relay starter is turning the engine ok.
It appears that there is no ground signal from ECU to activate starter relay (86/85) thus no voltage send to solenoid.
Now I am wondering if the ECU itself is gone or is there anything else than can lower the signal voltage ie. abs module that is clicking? Ignition switch may be involved?
Any experience, thoughts?
 
1 - 3 of 3 Posts
Top