Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1,219 Posts
Discussion Starter · #1 ·
Pulled my gearbox off the otehr day... had a major problem with the clutch slipping..... had the flywheel machined today, and started the process of replacing the clutch..... bit more difficult than the old 900 i have. .that was simple compared to this... also managed to tap a drain plug into the gearbox, so i can now change the oil
anyway.. just thought i would share my troubles with everyone

PS - i remember that when i replaced the clutch in my 900, that every gear change, the wheels would spin... and that was a NA 8v motor... none of this turbo power
i can just imagine what will happen when i take it for the test drive tomorrow arvo!!!!
 

·
Registered
Joined
·
1,219 Posts
Discussion Starter · #2 ·
ok.. taken the beast for a drive...
at the same time as replacing the clutch, i replaced my faulty coolant temp sensor aswell... now, the car just goes so much better! i unfortunately have the tyres break loose in 2nd and 3rd gears!

i discovered that the sensor must have always been telling the ecu that the engine was cold, so now it goes properly... (i have had the 9000 for almost a year now, and i was told when i bought it that it had a fast idle problem.. the temp sensor was dieing then! so now with it all fixed, i have to have a rematch race with my friend and his skyline... (last time we raced, my clutch was slipping constantly)
 
1 - 2 of 2 Posts
Top