Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 6 of 6 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
I have a few minor problems with power on my 95 aero hot recently, I checked the hoses all o.k.
Suspected the boost control valve so checked that seemed o.k.
Removed the purge line from it and blanked off, fault was still there.
I then looked at The boost bypass valve at the rear of the engine behind the plastic cover to the r/h side of the throttle body, with three pipes going to it.
I found this to be faulty causing my problems.
Whilst waiting for one from ebay I routed the pipework off this valve directly to the coresponding components.
I.e one from the snorkel adaptor on the inlet manifold to the dump valve, blanked off pipe from throttle body and ran car like this.
The car felt better already and have been driving like this for 3 - 4 days. Today though for some reason there seems to be a whine like a supercharger coming from the air intake, I rechecked my hoses which all seem to be fine. There is no smoke coming from the exhaust. I ftteed my new valve and put all pipework back to original but noise is still there?
Any ideas Im suspecting the turbo maybe, but am baffled why this has just happened. I have spent £1860 in 3 weeks on this car and am slowly loosing my edge with it.
The oil is only 1200miles old and I recently changed the exhaust manifold and had the turbo out and checked for play in the shaft and there was none.
I cleaned out the oil feed capilary line and pre lubricated the turbo before reinstallation, and has pulled strong.
Last year I dropped the sump and checked for sludge, it was immaculate as had had a full dealer service every 12k since new. It currently has 140k on the clock.

If it is the turbo I will take a sledge hammer to the car thats how annoyed I feel at the moment.

Any ideas would help, or ways to prove / disprove the turbo fault would be great.
 

·
Registered
Joined
·
77 Posts
Discussion Starter · #2 ·
Update!
Turbo is knackered compressor wheel vanes have had 3 broken on inlet side which has scratched housing, completely baffled as air filter is o.k wih no holes so have no idea what could of hit the compressor.
Am looking for new turbo if anyone has one TD04HL 15T.
Spoke to turbo company to rebuild turbo and for the money might just aswell buy new for diffenence they tell me the seals shaft and bearings were all in excellent condition considering my car has nearly 140k on clock, just needs new compressor as the scratching on inlet housing was before the compressor wheel so made no difference but still wanted £289.00 + vat.
 

·
Registered
Joined
·
1,590 Posts
RR,

great to hear you had a solution.

Mine sounds like yours and I was wondering if when yours went noisy, exactly where you felt the noise was emanating from when you had your head over the engine?

Hoping mine is only a turbo too. GT17 on mine after 150,000km. Goes hard, not smoking, and noise goes once warm. Maybe it is in its infancy?
 

·
Registered
Joined
·
77 Posts
Discussion Starter · #4 ·
1 - 6 of 6 Posts
Top