Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
My '93 2 litre (non turbo) has developed a slight misfire. It is most noticeable when cold or under hard acceleration, particularly with the aircon switched on.
Had similar symptoms a couple of months ago and the garage fitted a new ignition module. Surely this cannot be on its way out already?
Could there be another cause, or is the ignition module failing prematurely?
(This is not the ignition cassette which my car doesn't have)
 

·
Registered
Joined
·
383 Posts
Hi there,

What condition / age are the plugs?

If there's no DI Cassette and this model has ignition leads what condition are they in?

Does the car have a distributor? If so, what's the state of the cap? The slightest crack in a cap can intefere with the ignition. And what of the Advance/Retard. Is this done through vacuum lines or ECU? If vacuum, have you checked the vacuum pipes for splits or cracks?

Some ideas though I'm not familiar with your ignition setup though you have a few things to look at on Easter Day!!

HTH
Mally
 

·
Registered
Joined
·
1,219 Posts
Try a new rotor arm (inside the distributer) as they are cheap, and I found that mine started to go (on my '87 Turbo) and then suddenly just stopped working. What happened was the spark was jumping through the ceramic rotor arm to the metal shaft that the arm slid onto.
 

·
Registered
Joined
·
461 Posts
My 1986 9000i had a real appitite for distributer caps and rotor arms, getting through about one of each every year or so, and letting me know it was time for a change by missing a beat just like yours.

As they cost less than a tenner and ten minutes to replace both, I was never that upset about it.

Carl
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top