Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hi everyone,

My lower brake lights are not working for some reason. The high brake light works and all other lights are working (reverse, fog, lights).

I assume that if the high brake light is working then that means the switch is working and the signal is getting through to at least one brake light. I don't have a schematic but i would think that the high brake light and right hand light piggy backs off the rear left brake light (though I may be wrong). Checked all the globes and fuses. The tail lights that come on when you switch on the headlight are working fine it's just the brake lights in the same position that are not working.

Has anyone had this happen?

update: seems it might be the TWICE module. Is it possible to bypass the module and splice the 2 brake lights to the High brake light? I know I will still get the SID error each time I start the car but I can live with that rather that forking out for a new twice module, keys and locks.
 

·
Registered
Joined
·
191 Posts
Check for power and ground for the brake lights at the sockets and work back from there to the TWICE. Find out what part of the circuit is the problem. Odds of it being the TWICE are very low. You could rewire the entire circuit to bypass the TWICE if you really wanted to, but that wouldn't be my first choice. If you don't have the WIS for the diagrams, download it here: http://www.saabcentral.com/forums/showthread.php?t=622081
 

·
Super Moderator
Joined
·
2,689 Posts
Tangleberry,

Check the earth wiring in the rear left corner under the carpet. I had one which rusted off. Moved the connection to an adjacent stud and everything was better. The other problem I found was corrosion in the connector in the light cluster. A bit of a scrape with a sharp screwdriver sorted that one.

Paul @ Kippen.
 
1 - 3 of 3 Posts
Top