Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 5 of 5 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter · #1 ·
Imagine scenario - cold morning, jump in Aero, place key in starter, car starts and revs jump up to 1500 rpm and drop down to 600, then back up and down again for the 1st 5 minutes then fine. Cleaned the ICV - it was quite clean anyway. Reminds me of the old fashioned auto chokes that held the revs until it warmed up!

Any ideas?

or is this normal behaviour this time of the season!!
 

·
Registered
Joined
·
1,935 Posts
I'd check all the vacuum hoses for leaks and also that the large hose running into the back of the throttle body hasn't come loose. If it has it can be made to stay in with some semi-permanent gasket (eg Halfords' 'blue' one).
 

·
Registered
Joined
·
164 Posts
Mine still does this too (worse after a couple of hours on the motorway but happens from cold sometimes), so far I've had a new DI, IAC valve, the throttle chamber's been cleaned, and last but not least, a new head gasket (thank god I got a year's warranty with the car ), is it likely to be hoses or is there anything else I can look at, it's caused much scratching of heads at my local Saab garage!.
Cheers.
 

·
Registered
Joined
·
164 Posts
Hi Dave,

Sounds interesting, that could explain why it seems to happen in cold weather when I've got the heat on, or after a couple of hours on the motorway. This is way out of my league technically (the most work I ever did was on a B reg MG Metro ), I'd be interested in the experts comments!.
Cheers.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top