Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all saab 9 3 aero sport wagon . I have a very strange problem we’ll two to be exact . One is to do with my interior fan not working. All the controls light up fine on dash for climate control . I have removed the fan. The grey plug to it I have 12v accross black pin and red/green pin . I took out fan assembly took off the control module resistor pack thingy . Plugged that into the grey 4 pin plug . The 2 spade plugs out of it that plug into the motor shows 5v across two terminals . But when I plug the fan into it it doesn’t run . I have manually connected a paslode battery to fan which is 6v and it span straight away I’m confused . Sorry for long winded post just trying to put as much information as possible I am mechanically minded but struggling atm as my misses has cancer and I really want car to work properly for her
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
Hi all saab 9 3 aero sport wagon . I have a very strange problem we’ll two to be exact . One is to do with my interior fan not working. All the controls light up fine on dash for climate control . I have removed the fan. The grey plug to it I have 12v accross black pin and red/green pin . I took out fan assembly took off the control module resistor pack thingy . Plugged that into the grey 4 pin plug . The 2 spade plugs out of it that plug into the motor shows 5v across two terminals . But when I plug the fan into it it doesn’t run . I have manually connected a paslode battery to fan which is 6v and it span straight away I’m confused . Sorry for long winded post just trying to put as much information as possible I am mechanically minded but struggling atm as my misses has cancer and I really want car to work properly for her
KY07 UUW
 

·
Registered
Joined
·
1 Posts
I had the same issue as the seal behind the cabin air filter had perished and was allowing water into the motor. it hadn't seized but had caused damage to the resistor. I personally just replaced both the fan and the resistor as getting them out from behind the glove box was a pain in the... Neo brothers sell an aftermarket part for about £35. i would check the seal on the back of your filter as well.
 
1 - 3 of 3 Posts
Top