Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 20 of 22 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hi Guys hope someone can help
got a 59 plate 93 turbo TID 150 saloon with Grundig/Delphi sat nav (stopped working) 7 speakers and amp in left side of boot
bought this http://www.ebay.co.uk/itm/Saab-9-3-Car-DVD-GPS-Navi-Sat-Nav-USB-MP3-Stereo-Radio-Player-Head-Unit-Kit-ET-/322444751943?hash=item4b13347447:g:f0YAAOSwol5Yvp5f
came with connects2 part CTSSA001.2 and a fakra adapter
Problems Low level continuous Hiss (with or without engine running)
Above level 3 to 4 volume is VERY LOUD
FM reception very poor to non existent improves if i hold the silver part of the adapter and move it about connecting the blue power lead on the adapter makes no difference if anything its worse (original radio picks stations up OK )
AM reception non existent
many thanks in advance guys
Don
 

·
Registered
Joined
·
1,169 Posts
You may have damaged the wire at the crimp ...from memory the saab aerial fitment is at right angles?
Also depending on the amplifier system you have it may need the level adapter for the inputs.
ie http://www.ebay.co.uk/itm/CT53-SA01-Saab-9-3-2006-Onwards-Car-Stereo-Amplified-Active-Speaker-Adaptor-Lead-/181434002591?epid=706541924&hash=item2a3e4f2c9f:g:4xQAAMXQBLNTlcdk
Some bypass the amp and go straight from the head unit.
http://www.ebay.co.uk/itm/SAAB-9-3-93-2006-Active-Amplified-Stereo-Bypass-Wiring-Harness-Adaptor-PC9-415-/252149526497?hash=item3ab5486fe1:g:eIkAAOSwYHxWNABO
Some also fit ground loop isolators

Lots of info on this ...try the ice section over at uksaabs
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
thanks for that CJ its something to think about didn't really want to spend any more
was thinking about installing a new aerial and see it that helped
guess its my fault for thinking plug and play meant what it said not plug and play with wiring for the next 3 weeks lol
any more suggestions very welcome
Cheers Don
 

·
Registered
Joined
·
25 Posts
Discussion Starter #10
can anyone identify these 2 plugs
and where i can get adapters to fit the big one thanks
Don saab plug.jpg
 

·
Super Moderator
Joined
·
3,071 Posts
The one on the far left as ricfr says looks like aerial plug if the head unit has the old fashioned hole for the aerial to go into You can get an adaptor that goes in the hole and the other end plugs into it.
If the blue. Plug is gps and you have satnav on your head unit then you require a GPS Aeral .
 

·
Registered
Joined
·
25 Posts
Discussion Starter #13
thanks for that guys i can now confirm that a GPS aerial is no good for FM/AM
was supplied with a fakra adapter that would only fit the GPS so thats where i put it
now need to find out what type of adapter i need to fit the aerial lead the large round plug in post 10
again my thanks guys cheers
Don
 

·
Registered
Joined
·
25 Posts
Discussion Starter #16 (Edited)
http://www.ebay.co.uk/itm/CAR-RADIO-STEREO-ISO-TO-DIN-MALE-AERIAL-ARIEL-ARIAL-ANTENNA-ADAPTOR-PC5-27-/231177503299?epid=1625290902&hash=item35d340c243:g:kfsAAOxyeR9THcBG
Above for adaptor though you can prolly get it faster from a motor factors place near you or halfords .
The blue plug is for GPS only (sat nav )
Thanks for that mate but not the right one spent about 3 hours looking online i cant find one to fit
in the end went back to basics cut old plug of put a new one on it works thanks for the help
just undecided what to do about the low level hissing noise and very high volume can listen at about 2 to 4 (above 5 its way to loud)
live with it or try this Then you find some RCA ends at radio shack, or cut a set of RCAs up and strip the wires... then you connect them as follows:
Front Red RCA pole: 14
Front Red RCA shield: 10
Front White RCA pole: 15
Front White RCA shield: 11
Rear Red RCA pole: 13
Rear Red RCA shield: 9
Rear White RCA pole: 16
Rear White RCA shield: 12
or get one of these http://www.ebay.co.uk/itm/SAAB-9-3-9...kAAOSwYHxWNABO
 

·
Registered
Joined
·
25 Posts
Discussion Starter #17
well connected 4 RCA plugs to an ISO connector
and guess what Nothing no sound at all anyone know why?
Don
 

·
Super Moderator
Joined
·
3,071 Posts
I think ( but don't quote me on it ) cos I'm not good at all thease new fangled stereo systems in theae cars . Gone of the day of a tape deck and qraphic equaliser and the biggest set of speakers you could cram in your rear parcel shelf .
But to my understanding all the speakers are. Controlled through the amp in the boot
Through how you by-pass it I have no clue .
Did you buy that amp bypass from Ebay that was on the link above ?
Your hissing
Have you tried a ground loop isolator ?
Is the hissing constant even when car switched off ?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #20
The amp needs switching on cant remember what colour wire it is possibly blue/white.
Amp is switched on have sound with just ISO but its to loud can only use at about level 4so tried the RCA's to see if that would make volume more kinda normal
Don
 
1 - 20 of 22 Posts
Top