Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 4 of 4 Posts

·
Registered
Joined
·
346 Posts
Discussion Starter · #1 ·
Have fitted the new fuel pump at a cost of £365.00 yet the car still will not start. have fuel at the rail. any ideas Saab mechanic says it could be one of a hundred things. and it could have been something else that caused the pump to go. yet the pump has its own power supply and the relay is working and it is pumping. which proves it is getting the signal from the ecu. any ideas please
 

·
Registered
Joined
·
763 Posts
Had a similar problem recently, also replaced the fuel pump.....turned out to be a dodgy battery....try trickle charging your battery overnight and hopefully it should start in the morning. Make sure battery water topped up before charge and give it at least 16 hours charge. Good luck!
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #4 ·
Thank you all for your prompt attention. cured the problem. Fitted the pump the same way as the old one which I had problems with. and confused the fuel pipe with no non return valve as the return. just transposed the pipes and all was ok.

you would think that a pump costing that much would have very reliable instructions. in fact they were very poor. also broke the original elbow fitting, but as luck would have it a new one with a non return valve for the output was supplied. However it is larger than my pipework so I have had to make an extension up. So beware all of you with a 9000i with the old type pump. this is an expensive repair and also not a complete retro fit. Start looking in scrap yards now.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top