Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 2 of 2 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hello

car configuration:
-woesner pistons
-big cobra
-stock turbo (until soon)
-giant green injectors + 3.5b press regulator
- 3'' downpipe with catalysor
- 3'' hirsch exhaust
- DO88 intercooler with pipes
- RXP 251l/h fuel pump
- modified airbox with maptun filter
-biopower ecu tuning (320hp, 450Nm)

This is the situation:

My 9-5 aero (2001) have boost or so issue, i explain.

When i drive, everything is ok, if i suddently accelerate , the turbo needle goes directly into the red zone, perfect, but after it go down to the limit of the red and yellow zone (bad...).

Some time the car have vibration (missfire) when torque is needed and boost goes away....

I have change the fuel pump this morning, it already have a Walbro 255l/h, i suspect ir because when boost goes, the sound at the exhaust was like a dirty carburated engine at WOT, sound like someone spit inside the exhaust.

since i have change it i do not have this again, but the boost is never the same.

I have done the BPC bolt mod without any change....

I have change the DI K7 for an OEM from neobros, same , change the catalsysator for a mpatun downpipe, same......

i'm speechless.

any clue ?

Cheers

Laurent
 

·
Super Moderator
Joined
·
2,681 Posts
Kaurent,

I think you need to clean the valve that controls the turbo boost. Sound like you are hitting overboost when you accelerate hard. It's the black thingy on the top of the 'cobra' pipe going from the air mass meter to the turbo. It is just in front of the cylinder head on the left side ( as you look at the engine from the front ). It has an electrical connector and 3 rubber hoses leading down to the cobra and to the turbo.

Take it off and clean with carburettor cleaner.

Paul @ Kippen.
 
1 - 2 of 2 Posts
Top