Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 6 of 6 Posts

·
Registered
Joined
·
161 Posts
Discussion Starter · #1 ·
I have 4 of the heat elements not working, right across the centre of the rear window.
Has anybody any experience of repairing these, or is it something that is an impossibility?.
 

·
Registered
Joined
·
2,371 Posts
You used to be able to buy a product called Electrocure, which I think is pretty widely available, that you use like a paint across the breaks in the elements. You need to examine them very closely to find out where the breaks are, and if they are too big it won't work. The product is quite expensive for a small container (was about £5 when I bought mine), but cheaper than a new screen. Having said that, it failed to cure the one strip that doesn't work on mine, although it could be that I didn't locate all the breaks in the line. I'd previously used it successfullysome years ago (same tube, so perhaps it had age-expired).

Now, if you were to have an unfortunate accident, you could get the screen replaced for the cost of your windscreen excess.
 

·
Registered
Joined
·
2,242 Posts
Alan, I have a little bottle and if you want to cover postage and don't mind returning it, you can dip your brush and have a go at a repair.

I had 6 strips to fix on mine. I think what happens is that if people aren't careful how they load the tailgate, the elements get scratched.

David.
 

·
Registered
Joined
·
411 Posts
For others with this problem, here's how I solved mine.
I got a bottle of electro-conductive paint from a model railway shop, it's much cheaper than getting the same stuff from a car parts shop and it comes in a bigger bottle. It's exactly the same stuff, came in at about two pounds, fixes any number of breaks in the element, even quite extensive ones.
Steve
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top