Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 4 of 4 Posts

·
Registered
Joined
·
722 Posts
Discussion Starter · #1 ·
car is 2.3cs carlsson. LH 2.4.2 not trionic. Made a test switch a la townsend. Got strange results:
1 2 2 3 1 - no rpm signal(normal)
1 2 2 5 1 - no corresponding code on townsend site.

I checked these lots of times, so they are definately right. Can anyone help?The 2nd one is similar to o2 problem on townsend site, i think they say 1 2 2 2 5. They also say the check engine light should also be on constantly with this problem. Mine has never come on, but i know i have a problem with boost.Help!
I was going to take the car to a specialist to be hooked upto techII, do i need to now?will they just say the same thing?or should i take it?
Thanks for your help.
 

·
Registered
Joined
·
260 Posts
Paul,
Send me your e-mail address and I'll send a gif image of the Fault Code printout.
12251 (level of signal from position sensor too high / low): Position sensor indicates closed throttle and full load simultaneously at idling speed. Engine Temperature above 80C.
Test Data: Pin2: 0.2v at idle, 4v at full throttle.
Pin 10: 5v when position sensor not connected.

Is that any use??
Pete.
 

·
Registered
Joined
·
722 Posts
Discussion Starter · #4 ·
alos would this cause my boost/economy problems?
The boost goes well into red, immediately reduces to start of broken line, then gradually reduces to 2/3 yellow(at around 4k revs)
Economy is 25mpg on run, 18-22 around town, not thrashing it, but not driving as economically as i could.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top