Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 20 of 27 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
I recently had my turbo give up on me and stripped the engine to look for damage so pretty much in bits.

Put it all together (with a new turbo) and everything runs fine. Better than before actually but I'm getting the EML come one very often ie every day.

Code: P1260 Throttle Return Spring Too Low Force.

Any idea what this means?

Thanks in advance
 

·
Premium Member
Joined
·
3,778 Posts
Check the spring is in place mate :) check the action opening and the retrun is crisp. lube with wd40 or similar and recheck the action. is the throttle cable kinked or restricted in any way since the rebuid it may have got snagged or re routed??? check from th pedal forwards.
 

·
Registered
Joined
·
222 Posts
Discussion Starter #3
The spring is there and hasn't been removed. I did take the throttle cable off the actuator though but marked where it was before.

First off the box on the TB was making a clicking noise when turning the IGN. The cable was a bit tight so I slackened it a bit but the same fault comes back.

It drives OK just comes up with the EML with the same fault.
 

·
Registered
Joined
·
222 Posts
Discussion Starter #4
I can't seem to get to the bottom of this. I've tightened the cable (the thing with the clip at the TB) and tried all settings but no go.

Forgot to take EML light out and misses took it out today as I needed her car for work and it stalled straight after start and kept on stalling. Cleared code and all is fine but within a mile or two the light is back on.

Any ideas?

Can someone please summon Kez back from holiday? He's been away long enough and this needs fixing!! :D
 

·
Registered
Joined
·
222 Posts
Discussion Starter #6
Cheers Gareth.

The TB is not in limp mode and it's driving fine. I'll try and see if it'll wind back anyway and see what's what.

TB is clicking when the EML is on and I turn the ignition on which is odd? T7 I believe on a B205?
 

·
Premium Member
Joined
·
7,086 Posts
Boo lol

Hard to explain especially as only on my phone and too much alcohol intake but here goes

When you removed cable although you marked position it is possible its lost it'd position moved a full revolution and you only put back say half that to what you thought was the mark if this makes sense bit extreme what I said but hoping you will get understanding from it lol

You could take pipe of tb and check position of butterfly at various pedal positions
 

·
Registered
Joined
·
222 Posts
Discussion Starter #8
Alright for some Kez.... It's 11ºC here!

Just a thought. Could the wheel with the teeth on have moved a little bit rather than fully in limp mode? If in limp mode would it not limit the car to say 30MPH or something?

Only ever had one car go into limp mode (BMW) and that was limited to 30MPH and 2500RPM so I don't know if it's the same on Saab's?
 

·
Premium Member
Joined
·
7,086 Posts
1260 may set if throttle mechanism is not reset after you removed it mate

Reset throttle mechanism search wis for p1251 1252 sure that gives full diagnosis as they will be dependants
Have pm you some limited info lol
 

·
Premium Member
Joined
·
7,086 Posts
Yes limp home will have the same characteristics as the BMW although I think its the modulation of the motor out as you have removed the tb
Any probs aerojon should be able to tell you exactly what to do if you at unable to reset from info I sent

Bit more sober tonight going on boat trip tomorrow
It's started to cool down here the past cpl of days although still around 30deg
Back to reality on Friday lol
 

·
Registered
Joined
·
222 Posts
Discussion Starter #11
Thanks a lot Kez,

Followed the page full f stuff you PM'ed me this morning and done 130 miles since and no EML.

Seems like the car is back to normal again!
 

·
Premium Member
Joined
·
7,086 Posts
Lol

Just a thought mate when you get 5 if you would like to write a how to based around the info I sent and how you actually did .......you would then get your name in the hall of fame lmao
 

·
Registered
Joined
·
222 Posts
Discussion Starter #15
You mean something like this?

Kez sent me a load of info.
Printed it off.
Followed it step by step.
Turned the car on and all is OK.



:thumbsup:
 

·
Registered
Joined
·
4 Posts
You mean something like this?

Kez sent me a load of info.
Printed it off.
Followed it step by step.
Turned the car on and all is OK.



:thumbsup:
Hi,
I am having the same problem as you did with P1260. Could you or Kez send the info to me so I can try it on my car as well?

thanks.
 

·
Premium Member
Joined
·
7,086 Posts
lol.............no problem hope i saved it will look later when home fromwork or give ray a pm hopefully he saved it if i know him as he may be on here before i get home
 

·
Registered
Joined
·
4 Posts
Hi,
Got the info...thanks.

However, the info only talks about P1251-P1253, not P1260. Today, I replaced the throttle body with a working used one, but I get the check engine light and code P1260 right away again.

DO you have the diagnostic procedure for P1260?

thanks again.

 
1 - 20 of 27 Posts
Top