Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 16 of 16 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a Saab 9-3 vector 54-reg and the drivers side window has stopped working. (thankfully in the closed position)
When i operate any other window you can hear a click and can see the headlights dim very slightly but on the drivers side it does not make any difference even if i try the up position. I am suspecting the switch or wiring between the door and pillar but thought its worth asking to see if there is a common fault.
Hope someone can help
Thanks
 

·
Registered
Joined
·
3,172 Posts
Welcome to Saabscene,
No common problems that I've heard of, looks like it's going to have to be door trim off and test the wires starting at the motor.
 

·
Registered
Joined
·
22 Posts
my04 aero did exactly the same on drivers window,to diagnose mine i held the window switch in the down position and tapped the window motor with the door card off,it then started working.
Really easy to swap an i got a used motor for 40 quid baaargain.
 

·
Registered
Joined
·
57 Posts
I have the electric window problem in my car too. The passenger window won't go up or down from either switch, there's no click or dimming of lights and the speaker doesn't work in passenger door. I've checked all fuses mentioned in this forum for this problem and they're all OK. Also checked the contacts in the door, these are clean and fit well. Car is an 04 2.2TiD, any ideas?
 

·
Registered
Joined
·
375 Posts
I had exactly the same problem in my 04 2.2 TiD, whipped it into my indie, £40 later, sorted, mine didn't need a new motor or anything like that, they get jammed like any other moving part can
 

·
Registered
Joined
·
57 Posts
Cheers Toby, I think it's some electrical problem rather than a moving blockage cos of the speaker not working in the same door. Probably the front coil spring broke and severed the wiring ;o)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks for replies,
Looks like it could be the motor or switch, all the other electrics on the door work ok.
Will have to get round to taking the door panel off.
 

·
Registered
Joined
·
165 Posts
Elec window problem!

2009 ttid estate.

Drivers side window stopped working today. No previous issues really however I have had pinch protection on same window, could still be overridden and was reset at saab garage some time ago.

All other windows work from drivers side control. All switches illuminate. I've disconnected to reset without success. Wiring in hinge section is ok. Can still hear a clicking when pressed.

Is there anything you lot could recommend I could try?
Is it likely to be the motor?
I assume it wouldn't be a fuse if its still clocking when pressed?
If its a motor could I do it myself?
How do I get the door trim pannel off?

Any help appreciated!

Edit. Next post = post #100, do I get a prize?:D
 

·
Premium Member
Joined
·
3,778 Posts
does the leccy mirror still work?

If not then likely one of the connector blocks in the door handle area has come apart - its a common fault. I have posted vids of how to remove the door cards in the how too section, it literally takes 2 mins to do. there are beige and a black multi pin connectors it will be obvious if one or both have parted, i used a spot of nail varnish (not my own obviously) to fix them together to prevent this from happening again. drivers door a common one as it is regularly opened and shut and the connections eventually come apart though vibration.
 

·
Registered
Joined
·
165 Posts
Update,

I fixed my window using the above vid, very helpfull it was.

For some reason,I took it all apart, tried the new motor and the old motor, both worked.

Put it ack together with the old motor and it works perfectly... God knows what was wrong?

Gonna try to get a refund on the spare motor but if anyone needs one they can have it for wha I paid.
 

·
Registered
Joined
·
3 Posts
Hey there, reopening this thread. Passenger side front window not working, Stuck closed thankfully. Tried unplugging door hinge connector and disconnecting battery, no luck. There is a wee click on pressing the button. DOES THIS mean the motor has gone? I'd appreciate any advice before I tear it all apart ;-)
 

·
Administrator
Joined
·
5,054 Posts
if it doesn't work from either switch,i'd suspect failed motor or jammed regulator..
 
1 - 16 of 16 Posts
Top