Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 4 of 4 Posts

·
Registered
Joined
·
224 Posts
Discussion Starter · #1 ·
Hi. I just removed my electric seat because it wouldn't move in any direction, although the relay box under the seat was clicking every time any of the controls were moved. I replaced the relay box with another one but I get exactly the same behaviour.

The switches are working(?), the relay box is clicking so it must be ok, what else could it be?


Thanks in advance

Harry
 

·
Registered
Joined
·
2,277 Posts
Just a pure guess, but IF the clicking sounds are indeed the relays, and assuming that there are several motors in the seat base then I would say the power supply to the relays has been disrupted. (That is the power that the relays control through the closing of their contacts, going out to the motors to move the seat.) A strong suggestion would be to check either the fuse, if there is a seperate one for the motors, or the earth connection.

Nick.
 

·
Registered
Joined
·
346 Posts
After checking the above. it might be a good idea to see if the relay contacts are giving a voltage to the motors. relays of any type are renowned for this. The coil operates but the contacts become pitted and worn.
 

·
Registered
Joined
·
224 Posts
Discussion Starter · #4 ·
Problem solved. The relay box was replaced with an IDENTICAL one. There are 2 types:I assume pre-CS and some very first CSs is one, post 92 I assume it's the other. The part no's are different but all connectors are the same, however, they are not interchangeable.

Another one down, a few more to go....

Thanks

Harry
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top