Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi folks,

First of all I would like to say Hi to everyone, im also hoping there are a few techical / experienced guys out there that can help me today.

Ok Ive got the engine management light on,I have put a code reader on and pulled the p0400 code on a basic reader and the same fault pulls p0405 on a more advanced reader.
My original thoughts were to buy a new EGR Valve, which I did. No luck!

I then tested the loom, loom is fine!

I have checked all vacuum pipes intercooler ect. Although im very confident that its nothing like that as when I reset the light, its coming back straight away before I even start the car, therefore that would indicate its an electrical fault. I am fully out of ideas now.

The car is a SAAB 95 2004.

Any help would be very much appeciated.
 

·
SaabScene.com Premium Member
Joined
·
1,136 Posts
same code as I've had on my 9-3 TTID - cleaned first time then lasted for about 30k, second time limp mode on motorway and I decided to get a new one from Saab as it came with a 2 year warranty. Did you clear the error code? If so then could the new egr be faulty?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Im unsure of this code, Its something to do with the EGR. Yes the car starts and valves are new. Had a few garges look at it and they are also clueless.

Tempted to scrap the bloody thing!!
 

·
Registered
Joined
·
230 Posts
Here you go: And I have no idea what anyofitmeans.
P0400 Exhaust Gas Recirculation Plow Malfunction
P0401 Exhaust Gas Recirculation Flow Insufficient Detected
P0402 Exhaust Gas Recirculation flow Excessive Detected
P0403 Exhaust Gas Recirculation Circuit Malfunction
P0404 Exhaust Gas Recirculation Circuit Range/Performance
P0405 Exhaust Gas Recirculation Sensor A Circuit Low
 

·
Registered
Joined
·
313 Posts
I had a similar problem with my TTID, same as VirtualM. I cleaned the valve but for about a week after I still had the EML light come on intermittently, then all of a sudden it stopped coming on. So I've taken no further action as I want to wait until the better weather and do the job properly rather than be rushed by lack of day light and weather. But what I was advised to do was clean the EGR pipe as well as MAP sensor as these can cause issues with EGR even after cleaning or replacement as you did. Might be worth a try.
 
1 - 10 of 10 Posts
Top