Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 3 of 3 Posts

·
Registered
Joined
·
662 Posts
Discussion Starter · #1 ·
hi all,last tuesday when pulling away from a junction my carly went into LHM with the dreaded tcs warning light lit up.i stopped and lifted the bonnet and found that the hose that runs from the oneway valve on the bulkhead and goes to the throttle had come off (all now changed to silicon).i refitted the hose,switched off (didnt know if i should have done that first?),then restarted and it was fine after that.on wednesday wife phones me to say car has conked out and tcs light is on!!.i told her to limp home.i got home and disconnected the battery thinking that the "brain"has stored a fault code and this was the best way to reset it(for about 1 and a half hours).would i be right in thinking this??.when i reconnected the battery,trip,mile and temp etc still read the same(i thought that these would be "forgoten"after this time).on sunday wife comes back from shopping and its happened again .now has that hose comming off started this or could it be another problem??
hope you can help
cheers
simon
 

·
Registered
Joined
·
218 Posts
I had a similar problem with mine. It just needed a visit to the dealer and plugging onto their computer to rectify it. This was after I had spent £300 on a new throttle body!
Anyway go and see someone about it.
Southampton Saab were brilliant to me but it is a long way from Eastbourne.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top