Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 7 of 7 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter · #1 ·
Hello,

I have a 1990 9000 2.3 auto which I purchased secondhand about four months ago. Since then, I have noticed a few odd behaviours in the car.

1. Sometimes, (usually when the car is facing downhill) the reverse gear refuses to engage, and I merely roll as if I were in neutral.

2. When accelerating gently from a stop light, The transmission either seems to start in second or third (causing a lot of vibration), or it starts off fine, but then shifts too soon, causing the same sort of vibration.

3. When I pull to a stop, the revs will suddenly drop, the car will shudder, and it will return to normal. It does this maybe once or twice, then stops. I just had the air idler valve (is that the proper name?) cleaned out two weeks ago, and it helped for a while, but now I have the same problem.

What is going on here? I suspect the first two problems are transmission related, but the third is likely something else. What I'd like to ask everyone is: has anyone experienced anything like this, and if so, is it a major problem?
 

·
Registered
Joined
·
14,305 Posts
Hi Rocky and welcome to Saabscene

I'm afraid that you can write what I know about autos on the back of a very small postage stamp
, but there are a few around who know it a little better who should be able to offer some advice.
 

·
Registered
Joined
·
277 Posts
I've seen 1 and 2 before on a automatic plymouth voyager. It was leaking transmission fluid pretty bad and it would do things like that when it got low. We changed the filter and put in new fluid and havn't seen it since.
 

·
Registered
Joined
·
1,925 Posts
I would agree with Foecom, change the oil and filter in the gearbox first, bear in mind it can take up to 4 oil changes to really flush the box through, and see if it makes a difference before assuming the worst.
 

·
Registered
Joined
·
129 Posts
Discussion Starter · #5 ·
Well, I checked the transmission fluid level today (I brought it up to working temp., kept the engine running, and so forth...) and it looked a bit low. Normally, I would have just made an appointment to have the ATF and filter changed, but for the fact that about three weeks ago, my transmission cooler line sprang a leak, and I lost nearly all the fluid in the transmission. I got it fixed promptly, and refilled with new ATF, so I figured it would be ok to just top it off with some more fluid. And, that's what I did...

I added about 400 ml this afternoon (the dipstick was reading about half a litre low...), and so far, so good! It downshifts when neccesary, starts off in the proper gear, and so far, I've had no problem with reverse.

That being said, of course, I will get the fluid and filter changed in the near future, probably at the same time I do the brake and other fluids.

Thanks for your help, fellas!

happy SAABing...
 

·
Registered
Joined
·
187 Posts
hi and welcome to the board im glad you sorted your problem, you'll find that is usually the case with the vast amount of knowledge shared between folks here. it woul be interesting to see just how far flung us members of saabscene actually are, Italy,America,australia,Canada and of course the UK . i wonder where the the most obscure place a saab has been spotted? sorry for waffling take care and once again welcome
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top