Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 8 of 8 Posts

·
Registered
Joined
·
243 Posts
Discussion Starter · #1 ·
So there I was, driving along, glorious sunshine, Van Halen on the stereo...... hang on, Saabs don't come with a smoke machine as standard I thought as smoke started billowing from the drivers side facia top - then the engine cut out.......... ECU's gone right???? (haven't had a chance to get the car back home yet to look) or is there anything else it could be? The engine missed big time when I put my foot down hard this morning and was struggling to maintain idle just before it packed up completely.

Second part, does anyone know how much a 2nd hand one will cost me roughly (90 2000i b202) and any suggestions as to the best place to get a new one.... cheers
 

·
Registered
Joined
·
2,277 Posts
Hmm...The smoke would probably be caused by something electrical getting hot. Could be that a short circuit in the wiring caused the heat, and eventually the fuse did it's job and blew. The good side is that the ECU is probably OK. Check behind the fascia for burnt electrics, especially around the steering coloumn where movement could chafe a wire or two.
Here's hoping that it's good news.
Nick
 

·
Registered
Joined
·
260 Posts
I would have thought a prime candidate would be the ignition switch or its associated wiring. As far as I know, there aren't any ECU's in the dash aperture.
Like CDCarlsson says, have a good check in that area for burnt wiring etc.
Pete.
 

·
Registered
Joined
·
243 Posts
Discussion Starter · #4 ·
Thanks for the replies guys, still haven't managed to recover the car so haven't had time to check it properly yet. Went for the fuel system as a diagnosis because of the missfire and idle problems earlier in the day but it could be ignition. I could start the engine briefly a couple of times after whatever burnt out burnt out but it wouldn't run for more than a few seconds. The smoke came out of the demister vents by the front bulkhead rather than from under the dash, dunno I'll have a good look tomorow. Thanks again
 

·
Registered
Joined
·
243 Posts
Discussion Starter · #6 ·
Have to say I'm at a bit of a loss...... facia is in bits and I can't find any sign of charred wiring, heat damage etc etc. Non of the fuses have blown anywhere on the car, all the relays click and yet the car still wont run for more than a few seconds. Fuel pump is an obvious thought but then where did the smoke that came out of the facia top come from

Any ideas or sugestions glady welcomed!
 

·
Registered
Joined
·
1,908 Posts
Dave,

As smoke came out of demister vents, it is not so likely to have come from inside the fascia as the ducts should be sealed to enable airflow into the car.

Possibly fan motor burnt out?
Check which electrics work with engine off and ignition on (but keep fire extinguisher to hand

Not sure how fan - or other electric fault - would cause engine to run and stall though.

Could the imobilser (do you have one?) have activated? When the imobiliser auto activates on my car, the engine will fire and run for a couple of seconds (to burn up fuel, etc), and then cut off. The red LED on dash should flash if imobilser is active. To turn it off, either open car door and press key plip activate/deactivate button once, or leave door closed and press key plip twice (to lock and unlock door). Sorry if I am stating the obvious, hope it helps though.
 

·
Registered
Joined
·
243 Posts
Discussion Starter · #8 ·
Cheers Paul, does sound like an imobiliser problem - just wish the car had one Annoyingly every electrical circuit is working as it always has, the damn thing just wont start. I've go no idea whats going on realy at the moment so I'm taking it off for a second opinion. Fingers crossed I've missed something completely obvious.

Thanks again for all your sugestions people, much appreciated.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top