Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 10 of 10 Posts

·
Registered
Joined
·
95 Posts
I get that evry now and again, I clean all the contacts and sometimes on the bulbs with the two elements in them only one has gone, a general cleanup and bulb swap usualy does the trick for me, I seem to get through a lot of bulbs about 4 or 5 times a year I have to have a look and change at least one

Col
 

·
Registered
Joined
·
1,749 Posts
It's just possible that your two posts may be connected, also. If you search the archives, you'll find cases of the wrong brake light bulb causing the car not to stop running, so you may have a short.

Also, the trionic limits you to base boost when the brakes are applied, and I am sure I remember a case of someone fitting the wrong brake bulb and being limited to base boost.

Therefore I'd suggest you check out the bulbs, contacts and wiring in your rear lights as the others have suggested, since this may cure your strange engine problems too!
 

·
Registered
Joined
·
2,242 Posts
So we are talking about the pictogram display then?

I'd still say failed bulb, have you checked the roof/back window mounted bulb? Reason I ask is that I had exactly the same type of display in my Volvo, filament warning light would only come on when braking. I checked the brake lights and *both* worked.

In other words, I wasn't thinking to check the third bulb.

David.
 

·
Registered
Joined
·
116 Posts
The 9000 uses two bulbs for the taillights, one is a taillight and the other is stop and tail.

If the pictogram is on permanantly then the tail light filament has gone, if it only comes on when flashing it is a brake filament.

I'm not sure how to determine it other than having somone check all the high level and both main brake lights come on.

Lee
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top