Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
hi guys, i have a 2005 plate sabb 9-3 vector sport, ive been reading though the forums for the past weeks as ive been trying to solve this annoying problem that i have with my brake lights.

This is what was happening.

I would turn key on, the lights would just stay on. - brake peddle has no affect on the switching on or off of the lights.
I then changed the brake paddle switch, the lights still got stuck on for around 10 minutes then would go off, if id tap the peddle lightly the lights would go on and off, but then if i pressed it for 2 seconds or more the lights would just stick on again.

So i took it to a local auto eletrican, he fixed the problem, he said that i had a short.

Now having driven the car for a day, as the night struck, i have noticed that my brake lights are back out again, it appears that they work for the 1st 10 minutes of any journey and then they would just simply go off, but if i turn the ignition off, and then back on, they would work again for a further 10 minutes.
Im baffled, he's baffled, and i fare the worst- a new rear module???????
If any body has gone through this torchur before please let me know how to cure it.


much appreciated

thanks
 

·
Registered
Joined
·
1,775 Posts
Welcome to SaabScene. :)

I think the first thing I'd do is to change the brake-light bulbs and see how that goes. The bulbs are dual filament and if one filament breaks it can touch the other resulting in some strange effects caused by electricity feeding back the wrong way. I'd also check the bulb holders and the contacts when changing the bulbs, making sure that they are not touching.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
thanks for your advice SuperSwede66, they were the 1st things that i checked, also went to sabb and they confirmed that my model is built with single filament bulbs.
since then ive had an electrician look at it, he has done a temporary fix on one of the computers now resulting in the brake lights doing the opposite. So now they come on and work when brake peddle is pressed for the 1st 20 mins of any journey, after that they simply just stop working, and then only work when the ignition is switched off and then back on, which then it will only work for another 20mins and so on,
i think i will need a new ecu ? do you know if the problem can be identified in anyway before that before forking out £600+ plus on a new unit :eek:
 

·
Registered
Joined
·
16,524 Posts
The problem with modern cars and their computers is that a simple fix is not always easy. But I suspect that there is a fault in the system somewhere and a dealer of specialist should be able to find the source with the diagnostic computer. Probably quite cheap at a specialist rather than a main dealer.

Otherwise you will be spending a lot of money guessing, as you have done already.

If you are in Nottingham, you have a well regarded Saab independent near you in Ilkeston. Nottingham Saab also known as the Saab Performance Centre. I've not used him, but usually gets good reports.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
to anyone experiencing the same problems, its boils down to the rear module mounted in the boot being faulty, i think i will get it replaced, when its done ill let you know the out come.
 
1 - 8 of 8 Posts
Top