Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 4 of 4 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter · #1 ·
The little electic motor in the centre console of my 9-3, which runs for a few minutes after switch off, has become very noisy. In fact you can now hear it when the car is on the move (unless of course you turn the stereo up! )

Is there a way of getting it quiet again, or does it need replacing?

The car has done 74K miles.

Any ideas/suggestions would be appreciated.
 

·
Registered
Joined
·
20 Posts
-The little electic motor in the centre console of my 9-3,-

I think you are talking of the small ventilator which is located behind a small round grill in the center console. I had the same issue last year and this "hummmmm" sound was very very annoying. Here is what I did as far as I remember :
- I removed the glovebox, there are just a few screws to remove. Make sure you remove all of them. Be carefull with the glovebox light.
- Remove the screws of the sidepanel of the center console
- at this point, you can access behind the center console.
- take a vacuun cleaner and remove all the dust around there
- you can push from the inside the small grill which is in front of this ventilator
- vacuum this ventilator to make it spin fast and remove all its dust
- put a few drop of oils on this fan axle and make it spin fast to check if the sound disappeared. On my car, there was hairs and dirt around the axle. Once removed with a drop of oil, no sound anymore !

At this point, it doesn't make anymore this "hummmm" sound. Put back everything.

Time : 20mn to figure out how to remove the screws and to dismantle the glovebow+sidepanel, 5mn to clean and oil the fan axle and less than 10mn to put everything back.

Regards,
Mathias
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #3 ·
Yup, it's that motor!

Thanks for the advice, Mathias.

I'll give that a go (once the rain stops!), and report back.
 

·
Registered
Joined
·
182 Posts
Discussion Starter · #4 ·
Well, thanks to Mathias's instructions and some decent weather today , I got to the electric motor without too many problems.

The motor itself was actually fine, it runs very quiet. The problem was the fan was loose fitting against the centre console (it's only a push fit) and so was vibrating within its mounting.

The gasket (neoprene, I believe) that goes between the fan and the centre console didn't seem to be doing it's job properly in keeping everything snug and tight, whilst also damping any vibration.

Well, the odds of getting a replacement gasket around here on a Sunday are pretty remote, so whilst it was all in pieces I decided on a bit of improvisation. I cut a piece of thick packing cardboard to fit and placed it on the fan behind the gasket, and this was all that was needed to make everything a tight fit again (until I can get a new gasket).

It's all as quiet as a mouse now. In fact I now find myself checking to see if the fan is running after switch off, and I most certainly can't hear it whilst the engine is running (as I could before)!
 
1 - 4 of 4 Posts
Top