Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 2 of 2 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
Hi

I have a 2001 93 when the car is first started the aircon (climate control)works fine on a hot day full blast frezzing air then as the cabin cools fans slow all fine so far the display shows the air comming from the dash vents no problems.

Then after about 10 mins the dash vents close display still shows this should be where the air is comming from, then as the cabin gets hotter the fan gets faster you can hear it speeding up but the vents stay closed, you cannot open them manualy, switching the unit of and on has no effect even if you leave it off for some time.

But if you stop the car for 10mins then set off again all is well again untl again after a short while the vents again close.

Can the control be reset or reprogramed I have only had the car a short time dont know what happens when it calls for heat not cold

Any other ideas greatly appreciated
 

·
Registered
Joined
·
33 Posts
Hi

I have just had exactly these symptoms for about 2 months. All the displays show the air flow, the fan turns but no air flow this fault never occured when taken in to the dealer, I rang my dealer (Bell & Colvill, Guildford) whilst it was happening and drove directly there with no air flow.

They investigated and found that one of the sensors had failed and the air was getting colder and colder until ice formed in the system and blocked the air flow. Switching off for 10 minutes allowed the ice to thaw and the system to work correctly. i.e all the evidence had melted and nothing obvious to diagnose, sensor was changed and I now have cool air again.


What you describe may be the same problem

Best of Luck
 
1 - 2 of 2 Posts
Top