Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 7 of 7 Posts

·
Registered
Joined
·
197 Posts
Discussion Starter · #1 ·
Ignition switched on dipped lights are on. Move light switch from off to side and correctly side lights on. Move to headlights okay both dip and main but switching light switch off dip beam remains. The light switch itself seems okay after removing and checking on bench. The relay appears okay after checking on bench and seems to click as expected.(It is a double relay combined in engine bay.) Removed adjacent box for warning of bulb failure giving only side lights and also small black box forward of main double relay. NO improvement. Is this a problem with stalk which works correctly? ( As I see it a feed from ignition on is getting into dip beam circuit) Anybody any definite pointers? N-reg aero.
 

·
Registered
Joined
·
2,277 Posts
Having worked extensivly with relays of many types I can say that occasionally a magnetic stiction can occour causing the armature to remain stuck energised. This may well be your problem, just renew your relay.

Nick.
 

·
Registered
Joined
·
197 Posts
Discussion Starter · #5 ·
Two problems appeared to all intents together. ( I think this is co-incidence.) Washers came on with the ignition. Dis-connected front light wiper motors to correct this. Yes the problem with the headlights appeared out of the blue.
Thanks for your replies people, I am thinking it is probably the relay also.
Merry Xmas! (just finished a bottle of red.)
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top