Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,664 Posts
Discussion Starter · #1 ·
ABS System

I have lost all power assist on my 92 2.3 Turbo brakes.Reservoir full ,all lights out,
but seem unable to "Dump" pressure in system.
Pumping pedal with ignition off allways worked in the past but nomore,Mr Haynes says
there is a servo cylinder for assist and to power rear brakes.vehicle is of the road untill I can sort this and our one and only local dealer is as much use as a chocolate fireguard.So I need your help.
 

·
Registered
Joined
·
413 Posts
Re: ABS System

Relay / fuse box for ABS is under bonnet near brake fluid resovoir. I am looking in Haynes manual. The left hand relay is the hydraulic pump motor relay, left hand fuses are :- nearest relay ECU fuse 10amp, next is ECU fuse 30amp. Right hand relay is ECU relay and the one adjacent fuse is the hydraulic pump motor fuse 30amp.
May be worht checking these.
Can't gaurantee this info. is correct. Haynes are known to have errors in some of their manuals and it seems odd to me that the relevant fuses are adjacent to the 'other' relay. That's all the help I can give though.

Harvey
 

·
Registered
Joined
·
1,664 Posts
Discussion Starter · #3 ·
Re: ABS System

Thanks Harvey,I have checked the said fuses,all OK.The only thing to be certain about Haynes these days are the inaccuries.(is that how you spell it)
The thing that bugs me is my inability to exhaust the pressure in the accumulator.
 

·
Registered
Joined
·
1,610 Posts
Re: ABS System

Try a Larder!
Sorry, Couldn't resist that.
I am wondering whether it might be something too obvious like a break in the vacuum servo supply hose, as it appears by what was posted that the non assistance has happened overnight.
 

·
Registered
Joined
·
1,245 Posts
Re: ABS System

There is no vacuum servo. On the early ABS like this one there is an accumulator into which fluid is pumped up to something like 2000 psi. You should hear the pump working when you switch on the ignition. The ABS light goes out when the sysstem is up to pressure and it is this pressure which "assists" the brakes. With the ignition off this pressure will gradually dump every time toy press the pedal or if left overnight. In MikeH's case this is not happening. It would seem to me that there may be a stuck valve somewhere. Have a look at Townsend Imports site at
:http://www.townsendimports.com/
there may be some help there.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top